summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-www')
-rw-r--r--net-www/pound/ChangeLog9
-rw-r--r--net-www/pound/Manifest4
-rw-r--r--net-www/pound/files/digest-pound-1.61
-rw-r--r--net-www/pound/pound-1.6.ebuild60
4 files changed, 70 insertions, 4 deletions
diff --git a/net-www/pound/ChangeLog b/net-www/pound/ChangeLog
index 69c2357b8ed0..3b7d7f6be644 100644
--- a/net-www/pound/ChangeLog
+++ b/net-www/pound/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-www/pound
-# Copyright 2000-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-www/pound/ChangeLog,v 1.3 2003/11/01 20:49:30 pyrania Exp $
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/pound/ChangeLog,v 1.4 2004/01/27 19:12:41 mholzer Exp $
+
+*pound-1.6 (27 Jan 2004)
+
+ 27 Jan 2004; Martin Holzer <mholzer@gentoo.org> pound-1.6.ebuild:
+ Version bumped. Closes 39491
*pound-1.5 (01 Nov 2003)
diff --git a/net-www/pound/Manifest b/net-www/pound/Manifest
index 1c5bb9af9f11..7dadb27e2f49 100644
--- a/net-www/pound/Manifest
+++ b/net-www/pound/Manifest
@@ -1,8 +1,8 @@
-MD5 212e6ce2d9f0f35cf4e50e81fb124ab7 ChangeLog 556
+MD5 ed1c79ea1cdf7c1eb9d99a3d776b8ab7 ChangeLog 682
MD5 f61bfa064e3acdfcd826e4a38b121196 metadata.xml 161
MD5 4ae3fa54844e91ce95b6e63c7792a547 pound-1.4.ebuild 1372
MD5 c2dc68d0ddb56dd61ff66697d50df3f4 pound-1.5.ebuild 1372
-MD5 52a07effd58bc57b45a4c827945c8042 pound-1.6.ebuild 1373
+MD5 d2c22a9c0f6b7aef3bf430ea71cbafef pound-1.6.ebuild 1373
MD5 0b2e14a1793d6e6393cf13f015c58a7e files/digest-pound-1.6 58
MD5 ea7096804d2dc2e498de690fa440821d files/digest-pound-1.4 58
MD5 bc58884d636c60affb0267730438d6d9 files/digest-pound-1.5 58
diff --git a/net-www/pound/files/digest-pound-1.6 b/net-www/pound/files/digest-pound-1.6
new file mode 100644
index 000000000000..c46a088fc4b9
--- /dev/null
+++ b/net-www/pound/files/digest-pound-1.6
@@ -0,0 +1 @@
+MD5 530c26184be5da7715207423339cf2b1 Pound-1.6.tgz 121075
diff --git a/net-www/pound/pound-1.6.ebuild b/net-www/pound/pound-1.6.ebuild
new file mode 100644
index 000000000000..f59ea0313009
--- /dev/null
+++ b/net-www/pound/pound-1.6.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-www/pound/pound-1.6.ebuild,v 1.1 2004/01/27 19:12:41 mholzer Exp $
+
+MY_P=${P/p/P}
+
+DESCRIPTION="A http/https reverse-proxy and load-balancer."
+SRC_URI="http://www.apsis.ch/pound/${MY_P}.tgz"
+HOMEPAGE="http://www.apsis.ch/pound/"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~alpha ~mips ~hppa"
+IUSE="ssl"
+
+DEPEND="virtual/glibc
+ ssl? ( dev-libs/openssl )"
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ local myconf
+
+ ## check for ssl-support:
+ if [ "$(use ssl)" ]; then
+ myconf="${myconf} --with-ssl"
+ else
+ myconf="${myconf} --without-ssl"
+ fi
+
+ ## TODO: how to handle the missing "syslog" USE-flag?
+ ## check for syslog-support:
+ #if [ "$(use syslog)" ]; then
+ # myconf="${myconf} --with-log="
+ #else
+ # myconf="${myconf} --without-log"
+ #fi
+
+ econf ${myconf} || die "configure failed"
+ emake || die "compile failed"
+}
+
+src_install() {
+ dosbin pound
+ doman pound.8
+
+ dodoc README
+
+ exeinto /etc/init.d
+ newexe ${FILESDIR}/pound.init pound
+
+ insinto /etc
+ doins ${FILESDIR}/pound.cfg
+}
+
+pkg_postinst() {
+ einfo "No demo-/sample-configfile is included in the distribution -- read the man-page"
+ einfo "for more info."
+ einfo "A sample (localhost:8888 -> localhost:80) for gentoo is given in \"/etc/pound.cfg\"."
+}