summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-www/netscape-flash/netscape-flash-5.0.47-r4.ebuild')
-rw-r--r--net-www/netscape-flash/netscape-flash-5.0.47-r4.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/net-www/netscape-flash/netscape-flash-5.0.47-r4.ebuild b/net-www/netscape-flash/netscape-flash-5.0.47-r4.ebuild
new file mode 100644
index 000000000000..51dee7e1592f
--- /dev/null
+++ b/net-www/netscape-flash/netscape-flash-5.0.47-r4.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Author Karl Trygve Kalleberg <karltk@gentoo.org>
+# /space/gentoo/cvsroot/gentoo-x86/net-www/netscape-flash/netscape-flash-5.0.47-r3.ebuild,v 1.1 2001/12/13 15:45:39 hallski Exp
+
+S=${WORKDIR}/flash_linux
+DESCRIPTION="Macromedia Shockwave Flash Player"
+SRC_URI="http://www.ibiblio.org/gentoo/distfiles/${P}.tar.gz"
+HOMEPAGE="http://www.macromedia.com"
+
+src_install() {
+ cd ${S}
+ exeinto /opt/netscape/plugins
+ insinto /opt/netscape/plugins
+ doexe libflashplayer.so
+ doins ShockwaveFlash.class
+ dodoc README ReadMe.htm
+
+ if [ "`use mozilla`" ] ; then
+ dodir /usr/lib/mozilla/plugins
+ dosym /opt/netscape/plugins/libflashplayer.so \
+ /usr/lib/mozilla/plugins/libflashplayer.so
+ dosym /opt/netscape/plugins/ShockwaveFlash.class \
+ /usr/lib/mozilla/plugins/ShockwaveFlash.class
+ fi
+}