summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-wireless/bluez-libs/bluez-libs-3.30.ebuild')
-rw-r--r--net-wireless/bluez-libs/bluez-libs-3.30.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/net-wireless/bluez-libs/bluez-libs-3.30.ebuild b/net-wireless/bluez-libs/bluez-libs-3.30.ebuild
new file mode 100644
index 000000000000..ebe174058e81
--- /dev/null
+++ b/net-wireless/bluez-libs/bluez-libs-3.30.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-wireless/bluez-libs/bluez-libs-3.30.ebuild,v 1.1 2008/04/12 00:14:12 betelgeuse Exp $
+
+DESCRIPTION="Bluetooth Userspace Libraries"
+HOMEPAGE="http://bluez.sourceforge.net/"
+SRC_URI="http://bluez.sourceforge.net/download/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~sh ~sparc ~x86"
+
+IUSE="debug"
+DEPEND="!net-wireless/bluez-sdp"
+RDEPEND="${DEPEND}"
+
+src_compile() {
+ econf $(use_enable debug) || die "econf failed"
+ if use debug ; then
+ echo "#define SDP_DEBUG 1" >> config.h
+ fi
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "make install failed"
+ dodoc AUTHORS ChangeLog README || die
+}
+
+pkg_postinst() {
+ elog "If you are upgrading from =${CATEGORY}/${PN}-2*,"
+ elog "the ABI version of libbluetooth has changed."
+ elog "Please run:"
+ elog " revdep-rebuild --library libbluetooth.so.1"
+}