summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-proxy/3proxy/3proxy-0.5.3a.ebuild')
-rw-r--r--net-proxy/3proxy/3proxy-0.5.3a.ebuild57
1 files changed, 57 insertions, 0 deletions
diff --git a/net-proxy/3proxy/3proxy-0.5.3a.ebuild b/net-proxy/3proxy/3proxy-0.5.3a.ebuild
new file mode 100644
index 000000000000..11aa27292a00
--- /dev/null
+++ b/net-proxy/3proxy/3proxy-0.5.3a.ebuild
@@ -0,0 +1,57 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-proxy/3proxy/3proxy-0.5.3a.ebuild,v 1.1 2006/11/09 14:43:46 mrness Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="really tiny cross-platform proxy servers set"
+HOMEPAGE="http://www.security.nnov.ru/soft/3proxy/"
+SRC_URI="http://www.security.nnov.ru/soft/3proxy/${PV}/${P}.tgz"
+
+LICENSE="3proxy"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND=""
+
+S=${WORKDIR}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ sed -i \
+ -e "/^CFLAGS/s:-g -O2:${CFLAGS}:" \
+ -e "/^LDFLAGS/s:-O2:${LDFLAGS}:" \
+ Makefile.unix || die "sed Makefile"
+ sed -i 's:/usr/local::' src/stringtable.c || die "sed stringtable"
+ find . -type f -print0 | xargs -0 chmod a-x
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ LN="$(tc-getCC)" \
+ -f Makefile.unix \
+ || die
+}
+
+src_install() {
+ local x
+
+ cd "${S}"/src
+ dobin 3proxy || die "dobin 3proxy failed"
+ for x in proxy socks pop3p tcppm udppm mycrypt dighosts ; do
+ newbin ${x} ${PN}-${x} || die "newbin ${x} failed"
+ [[ -f ${S}/man/${x}.8 ]] \
+ && newman "${S}"/man/${x}.8 ${PN}-${x}.8
+ done
+
+ dodoc $(find "${S}"/cfg -type f)
+ doman "${S}"/man/3proxy*.[38]
+
+ cd "${S}"
+ dodoc Changelog Readme Release.notes
+ dodoc $(find "${S}"/doc -name '*.txt')
+ dohtml $(find "${S}"/doc -name '*.html')
+}