summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/transmission/transmission-0.96.ebuild')
-rw-r--r--net-p2p/transmission/transmission-0.96.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/net-p2p/transmission/transmission-0.96.ebuild b/net-p2p/transmission/transmission-0.96.ebuild
new file mode 100644
index 000000000000..0587d7b067fa
--- /dev/null
+++ b/net-p2p/transmission/transmission-0.96.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/transmission/transmission-0.96.ebuild,v 1.1 2007/12/12 05:35:10 compnerd Exp $
+
+DESCRIPTION="Simple BitTorrent client"
+HOMEPAGE="http://transmission.m0k.org/"
+SRC_URI="http://download.m0k.org/transmission/files/${P}.tar.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+IUSE="gtk"
+
+RDEPEND=">=dev-libs/glib-2.6
+ >=dev-libs/openssl-0.9.8
+ gtk? ( >=x11-libs/gtk+-2.6 )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ >=dev-util/pkgconfig-0.19
+ gtk? ( >=dev-util/intltool-0.35 )"
+
+src_compile() {
+ econf $(use_with gtk) --without-wx || die "configure failed"
+ emake || die "build failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "install failed"
+ dodoc AUTHORS NEWS
+}