summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-p2p/qtella/qtella-0.6.4.ebuild')
-rw-r--r--net-p2p/qtella/qtella-0.6.4.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/net-p2p/qtella/qtella-0.6.4.ebuild b/net-p2p/qtella/qtella-0.6.4.ebuild
new file mode 100644
index 000000000000..d9345beed939
--- /dev/null
+++ b/net-p2p/qtella/qtella-0.6.4.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-p2p/qtella/qtella-0.6.4.ebuild,v 1.1 2004/04/28 17:45:44 squinky86 Exp $
+
+inherit kde-base
+
+IUSE="kde"
+use kde && need-kde 3 || need-qt 3
+
+SRC_URI="mirror://sourceforge/qtella/${P}.tar.gz"
+RESTRICT="nomirror"
+HOMEPAGE="http://www.qtella.net"
+DESCRIPTION="Excellent QT/KDE Gnutella Client"
+
+SLOT="3" # why??
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+export MAKEOPTS="$MAKEOPTS -j1"
+
+src_compile() {
+ kde_src_compile myconf
+ use kde || myconf="$myconf --with-kde=no"
+ kde_src_compile configure make
+}