summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-misc/openvpn/openvpn-1.4.2.ebuild')
-rw-r--r--net-misc/openvpn/openvpn-1.4.2.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-misc/openvpn/openvpn-1.4.2.ebuild b/net-misc/openvpn/openvpn-1.4.2.ebuild
new file mode 100644
index 000000000000..0a85546061e8
--- /dev/null
+++ b/net-misc/openvpn/openvpn-1.4.2.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-misc/openvpn/openvpn-1.4.2.ebuild,v 1.1 2003/08/04 00:40:41 warpzero Exp $
+
+IUSE="ssl"
+
+S=${WORKDIR}/${P}
+DESCRIPTION="OpenVPN is a robust and highly flexible tunneling application"
+SRC_URI="http://easynews.dl.sourceforge.net/sourceforge/openvpn/${P}.tar.gz"
+HOMEPAGE="http://openvpn.sourceforge.net/"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~ppc ~sparc"
+
+DEPEND=">=dev-libs/lzo-1.07
+ virtual/linux-sources
+ ssl? ( >=dev-libs/openssl-0.9.6 )"
+
+src_compile() {
+
+ local myconf
+
+ use ssl || myconf='--disable-ssl --disable-crypto'
+
+# ./autogen.sh || die
+ econf || die
+ emake || die
+}
+
+src_install() {
+
+ make DESTDIR=${D} install || die
+
+ dodoc COPYING CHANGES INSTALL PORTS README
+ insinto /etc/init.d ; doins ${FILESDIR}/openvpn
+ chmod 755 ${D}/etc/init.d/openvpn
+
+}