summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-mail')
-rw-r--r--net-mail/ezmlm-idx/ChangeLog9
-rw-r--r--net-mail/ezmlm-idx/ezmlm-idx-6.0.0.ebuild77
-rw-r--r--net-mail/ezmlm-idx/files/digest-ezmlm-idx-6.0.06
3 files changed, 90 insertions, 2 deletions
diff --git a/net-mail/ezmlm-idx/ChangeLog b/net-mail/ezmlm-idx/ChangeLog
index 403d337d1ed5..94e8a8517c14 100644
--- a/net-mail/ezmlm-idx/ChangeLog
+++ b/net-mail/ezmlm-idx/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-mail/ezmlm-idx
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-mail/ezmlm-idx/ChangeLog,v 1.16 2006/11/23 16:04:43 vivo Exp $
+# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/ezmlm-idx/ChangeLog,v 1.17 2007/09/16 09:06:24 hollow Exp $
+
+*ezmlm-idx-6.0.0 (16 Sep 2007)
+
+ 16 Sep 2007; Benedikt Böhm <hollow@gentoo.org> +ezmlm-idx-6.0.0.ebuild:
+ version bump; fixes #47668, #83606 and #152503
23 Nov 2006; Francesco Riosa <vivo@gentoo.org> ezmlm-idx-0.40-r2.ebuild:
dev-db/mysql => virtual/mysql
diff --git a/net-mail/ezmlm-idx/ezmlm-idx-6.0.0.ebuild b/net-mail/ezmlm-idx/ezmlm-idx-6.0.0.ebuild
new file mode 100644
index 000000000000..fa4ae6b6474d
--- /dev/null
+++ b/net-mail/ezmlm-idx/ezmlm-idx-6.0.0.ebuild
@@ -0,0 +1,77 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-mail/ezmlm-idx/ezmlm-idx-6.0.0.ebuild,v 1.1 2007/09/16 09:06:24 hollow Exp $
+
+EZMLM_P=ezmlm-0.53
+
+inherit eutils fixheadtails
+
+DESCRIPTION="Simple yet powerful mailing list manager for qmail"
+HOMEPAGE="http://www.ezmlm.org"
+SRC_URI="http://cr.yp.to/software/${EZMLM_P}.tar.gz
+ http://www.ezmlm.org/archive/${PV}/${P}.tar.gz"
+
+LICENSE="as-is"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~mips ~ppc ~sparc ~x86"
+IUSE="mysql postgres"
+
+DEPEND="
+ mysql? ( virtual/mysql )
+ postgres? ( dev-db/libpq )
+"
+RDEPEND="${DEPEND}
+ virtual/qmail"
+
+S="${WORKDIR}"/${EZMLM_P}
+
+pkg_setup() {
+ if use mysql && use postgres; then
+ die "cannot build mysql and pgsql support at the same time"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ mv "${WORKDIR}"/${P}/* "${S}" || die
+ cd "${S}"
+
+ epatch "${S}"/idx.patch
+
+ ht_fix_file Makefile
+
+ echo /usr/bin > conf-bin
+ echo /usr/lib/ezmlm > conf-lib
+ echo /etc/ezmlm > conf-etc
+ echo /usr/share/man > conf-man
+ echo /var/qmail > conf-qmail
+
+ echo $(tc-getCC) ${CFLAGS} -I/usr/include/{my,postgre}sql > conf-cc
+ echo $(tc-getCC) ${CFLAGS} > conf-ld
+
+ # fix DESTDIR and skip cat man-pages
+ sed -e "s:\(/install\) \(\"\`head\):\1 ${D}\2:" \
+ -e "s:\(./install.*\) < MAN$:grep -v \:/cat MAN | \1:" \
+ -e "s:\(\"\`head -n 1 conf-etc\`\"/default\):${D}\1:" \
+ -i Makefile
+
+ # ezmlm-mktab-{my|pg}sql may or may not be made
+ sed -i -e "s/\(^.*mktab\)/?\1/" BIN
+}
+
+src_compile() {
+ emake it man || die "make failed"
+
+ if use mysql; then
+ emake mysql || die "make mysql failed"
+ elif use postgres; then
+ emake pgsql || die "make pgsql failed"
+ fi
+}
+
+src_install () {
+ dodir /usr/bin /usr/lib/ezmlm /etc/ezmlm /usr/share/man
+ dobin ezmlm-cgi
+
+ make DESTDIR="${D}" setup || die "make setup failed"
+}
diff --git a/net-mail/ezmlm-idx/files/digest-ezmlm-idx-6.0.0 b/net-mail/ezmlm-idx/files/digest-ezmlm-idx-6.0.0
new file mode 100644
index 000000000000..38c104e82589
--- /dev/null
+++ b/net-mail/ezmlm-idx/files/digest-ezmlm-idx-6.0.0
@@ -0,0 +1,6 @@
+MD5 108c632caaa8cdbfd3041e6c449191b2 ezmlm-0.53.tar.gz 62693
+RMD160 6d366de2d7028a984ba454f1bec9d2d9f495c88b ezmlm-0.53.tar.gz 62693
+SHA256 9639c3a5cc49d417f30e6cd7d8c5e2c6945262953c143134035889d8aa1004b9 ezmlm-0.53.tar.gz 62693
+MD5 e3dc23efef40cf033480e1f10c7742b2 ezmlm-idx-6.0.0.tar.gz 659996
+RMD160 1c875dfb16191cc018d0c56ac627db918a220d05 ezmlm-idx-6.0.0.tar.gz 659996
+SHA256 625b2e54818e694c04a4c8d32bd0e382867df29a147067073a8cdb9b252aa54e ezmlm-idx-6.0.0.tar.gz 659996