summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/ortp/ortp-0.7.1-r1.ebuild')
-rw-r--r--net-libs/ortp/ortp-0.7.1-r1.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-libs/ortp/ortp-0.7.1-r1.ebuild b/net-libs/ortp/ortp-0.7.1-r1.ebuild
new file mode 100644
index 000000000000..1f4e1c6fe3ef
--- /dev/null
+++ b/net-libs/ortp/ortp-0.7.1-r1.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/ortp/ortp-0.7.1-r1.ebuild,v 1.1 2006/01/08 07:29:47 dragonheart Exp $
+
+DESCRIPTION="Open Real-time Transport Protocol (RTP) stack"
+HOMEPAGE="http://www.linphone.org/ortp/"
+SRC_URI="http://www.linphone.org/ortp/sources/${P}.tar.gz"
+
+IUSE="ipv6"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86 ~amd64"
+
+DEPEND="=dev-libs/glib-2*
+ >=dev-util/pkgconfig-0.9.0"
+RDEPEND="=dev-libs/glib-2*"
+
+src_compile() {
+ econf $(use_enable ipv6) || die 'configure failed'
+ emake || die 'make compile failed'
+}
+
+src_install() {
+ emake DESTDIR=${D} install || die "Make install failed"
+ sed -i -e "s:^\(#include <\)\(glib\.h>\)$:\1glib-2.0/\2:" ${D}/usr/include/ortp/rtpport.h
+
+ dodoc README ChangeLog AUTHORS TODO NEWS
+ dodoc docs/*.txt
+}