summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libssh2/libssh2-1.2.2.ebuild')
-rw-r--r--net-libs/libssh2/libssh2-1.2.2.ebuild47
1 files changed, 0 insertions, 47 deletions
diff --git a/net-libs/libssh2/libssh2-1.2.2.ebuild b/net-libs/libssh2/libssh2-1.2.2.ebuild
deleted file mode 100644
index b91fccb2d264..000000000000
--- a/net-libs/libssh2/libssh2-1.2.2.ebuild
+++ /dev/null
@@ -1,47 +0,0 @@
-# Copyright 1999-2010 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-libs/libssh2/libssh2-1.2.2.ebuild,v 1.9 2010/03/28 17:57:18 armin76 Exp $
-
-EAPI="2"
-
-DESCRIPTION="Library implementing the SSH2 protocol"
-HOMEPAGE="http://www.libssh2.org/"
-SRC_URI="http://www.${PN}.org/download/${P}.tar.gz"
-
-LICENSE="BSD"
-SLOT="0"
-KEYWORDS="alpha amd64 arm hppa ia64 ~mips ppc ppc64 s390 sh sparc x86 ~x86-fbsd"
-IUSE="gcrypt zlib"
-
-DEPEND="!gcrypt? ( dev-libs/openssl )
- gcrypt? ( dev-libs/libgcrypt )
- zlib? ( sys-libs/zlib )"
-RDEPEND="${DEPEND}"
-
-src_configure() {
- local myconf
-
- if use gcrypt; then
- myconf="--with-libgcrypt"
- else
- myconf="--with-openssl"
- fi
-
- econf \
- $(use_with zlib libz) \
- ${myconf}
-}
-
-src_test() {
- if [[ ${EUID} -ne 0 ]]; then #286741
- ewarn "Some tests require real user that is allowed to login."
- ewarn "ssh2.sh test disabled."
- sed -e 's:ssh2.sh::' -i tests/Makefile
- fi
- emake check || die
-}
-
-src_install() {
- emake DESTDIR="${D}" install || die "emake install failed"
- dodoc README
-}