summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-libs/libbt/libbt-1.01.ebuild')
-rw-r--r--net-libs/libbt/libbt-1.01.ebuild32
1 files changed, 32 insertions, 0 deletions
diff --git a/net-libs/libbt/libbt-1.01.ebuild b/net-libs/libbt/libbt-1.01.ebuild
new file mode 100644
index 000000000000..da31bae9a30f
--- /dev/null
+++ b/net-libs/libbt/libbt-1.01.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-libs/libbt/libbt-1.01.ebuild,v 1.1 2004/04/11 01:09:28 squinky86 Exp $
+
+DESCRIPTION="libBT is an impementation of the BitTorrent core protocols in C"
+HOMEPAGE="http://libbt.sourceforge.net"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+RESTRICT="nomirror"
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+IUSE=""
+
+DEPEND="dev-libs/openssl
+ net-misc/curl
+ sys-fs/e2fsprogs"
+
+src_compile () {
+ econf || die
+ sed -i -e "s:-g -Wall:${CFLAGS} -g -Wall:g" src/Makefile
+ emake || die
+}
+
+src_install () {
+ dobin src/btlist src/btget src/btcheck
+ doman man/*
+ insinto /usr/include/libbt
+ doins include/*
+ dolib src/libbt.a
+ dodoc CHANGELOG COPYING CREDITS README docs/*
+}