summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-irc')
-rw-r--r--net-irc/pisg/ChangeLog9
-rw-r--r--net-irc/pisg/pisg-0.72.ebuild55
2 files changed, 62 insertions, 2 deletions
diff --git a/net-irc/pisg/ChangeLog b/net-irc/pisg/ChangeLog
index afed8bbffc2b..b05bdb93b92f 100644
--- a/net-irc/pisg/ChangeLog
+++ b/net-irc/pisg/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for net-irc/pisg
-# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-irc/pisg/ChangeLog,v 1.55 2007/06/03 15:34:51 armin76 Exp $
+# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/pisg/ChangeLog,v 1.56 2008/07/07 18:24:27 armin76 Exp $
+
+*pisg-0.72 (07 Jul 2008)
+
+ 07 Jul 2008; Raúl Porcel <armin76@gentoo.org> +pisg-0.72.ebuild:
+ Version bump
03 Jun 2007; Raúl Porcel <armin76@gentoo.org> -pisg-0.70.ebuild:
old
diff --git a/net-irc/pisg/pisg-0.72.ebuild b/net-irc/pisg/pisg-0.72.ebuild
new file mode 100644
index 000000000000..bfd86407128b
--- /dev/null
+++ b/net-irc/pisg/pisg-0.72.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-irc/pisg/pisg-0.72.ebuild,v 1.1 2008/07/07 18:24:27 armin76 Exp $
+
+inherit perl-app
+
+DESCRIPTION="Perl IRC Statistics Generator"
+HOMEPAGE="http://pisg.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86 ~x86-fbsd"
+
+IUSE=""
+
+RDEPEND="dev-lang/perl
+ dev-perl/Text-Iconv"
+DEPEND="dev-lang/perl
+ >=sys-apps/sed-4"
+
+src_unpack() {
+ unpack ${A}
+
+ sed -i \
+ -e 's!lang\.txt!/usr/share/pisg/lang.txt!' \
+ -e 's!layout/!/usr/share/pisg/layout/!' \
+ "${S}"/modules/Pisg.pm \
+ || die "sed failed"
+}
+
+src_compile() {
+ einfo "Nothing to compile"
+}
+
+src_install() {
+ perlinfo
+
+ dobin pisg || die "dobin failed"
+
+ insinto "${VENDOR_LIB}"
+ doins -r modules/. || die "doins failed"
+
+ insinto /usr/share/pisg
+ doins -r gfx layout lang.txt || die "doins failed"
+
+ dodoc \
+ docs/{CREDITS,Changelog,FORMATS,pisg-doc.txt} \
+ docs/dev/API pisg.cfg README || die "dodoc failed"
+ doman docs/pisg.1 || die "doman failed"
+ dohtml docs/pisg-doc.html || die "dohtml failed"
+}
+
+pkg_postinst() {
+ einfo "The pisg images have been installed in /usr/share/pisg/gfx"
+}