summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-im/gabber/gabber-0.8.7.12.ebuild')
-rw-r--r--net-im/gabber/gabber-0.8.7.12.ebuild13
1 files changed, 11 insertions, 2 deletions
diff --git a/net-im/gabber/gabber-0.8.7.12.ebuild b/net-im/gabber/gabber-0.8.7.12.ebuild
index d987667c0964..922b38b77d7d 100644
--- a/net-im/gabber/gabber-0.8.7.12.ebuild
+++ b/net-im/gabber/gabber-0.8.7.12.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-im/gabber/gabber-0.8.7.12.ebuild,v 1.2 2003/03/04 21:29:49 foser Exp $
+# $Header: /var/cvsroot/gentoo-x86/net-im/gabber/gabber-0.8.7.12.ebuild,v 1.3 2003/04/26 23:21:13 liquidx Exp $
inherit flag-o-matic
@@ -10,6 +10,7 @@ DESCRIPTION="The GNOME Jabber Client"
SRC_URI="mirror://gentoo/${P}.tar.gz"
HOMEPAGE="http://gabber.sourceforge.net"
+IUSE="ssl crypt xmms"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~x86"
@@ -25,6 +26,12 @@ DEPEND=">=gnome-base/gnome-libs-1.4.1.7
RDEPEND="${DEPEND} nls? ( sys-devel/gettext )"
+src_unpack() {
+ unpack ${A}
+ cd ${S}/omf-install
+ sed -i -e "s/-scrollkeeper-update.*//" Makefile.in
+}
+
src_compile() {
replace-flags "-O3" "-O2"
@@ -33,7 +40,7 @@ src_compile() {
local myconf
use ssl \
- && myconf="${myconf} --enable-ssl" \
+ && myconf="${myconf} --with-ssl-dir=/usr" \
|| myconf="${myconf} --disable-ssl"
use nls \
&& myconf="${myconf} --enable-nls" \
@@ -48,4 +55,6 @@ src_compile() {
src_install() {
einstall || die
+ # make sure we don't overwrite the scrollkeeper db
+ rm -rf ${D}/var/lib/scrollkeeper
}