summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-fs/coda')
-rw-r--r--net-fs/coda/ChangeLog13
-rw-r--r--net-fs/coda/Manifest7
-rw-r--r--net-fs/coda/coda-6.0.3.ebuild119
-rw-r--r--net-fs/coda/files/auth247
-rw-r--r--net-fs/coda/files/coda-6.0.3-iowr.patch12
-rw-r--r--net-fs/coda/files/coda-update52
-rw-r--r--net-fs/coda/files/codasrv39
-rw-r--r--net-fs/coda/files/digest-coda-6.0.31
-rw-r--r--net-fs/coda/files/venus30
-rw-r--r--net-fs/coda/metadata.xml10
10 files changed, 330 insertions, 0 deletions
diff --git a/net-fs/coda/ChangeLog b/net-fs/coda/ChangeLog
new file mode 100644
index 000000000000..99fb6ffb55d1
--- /dev/null
+++ b/net-fs/coda/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for net-fs/coda
+# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/coda/ChangeLog,v 1.1 2004/03/23 20:18:49 dragonheart Exp $
+
+*coda-6.0.3 (24 Mar 2004)
+
+ 24 Mar 2004; Daniel Black <dragonheart@gentoo.org> coda-6.0.3.ebuild,
+ files/auth2, files/coda-6.0.3-iowr.patch, files/coda-update, files/codasrv,
+ files/venus:
+ inital import based off bug #26132. Still work in progress - I want to
+ automate the install a lot more but its hard! Thanks to Michael C. Ferguson
+ mcf@augustmail.com who put together the intial ebuilds for this
+
diff --git a/net-fs/coda/Manifest b/net-fs/coda/Manifest
new file mode 100644
index 000000000000..b8e2e50600ad
--- /dev/null
+++ b/net-fs/coda/Manifest
@@ -0,0 +1,7 @@
+MD5 bfc5c2205f5d9a1ffb84836d5019a2ce coda-6.0.3.ebuild 2864
+MD5 2d948d52c60b9074ce7c80d9fd6953de files/venus 584
+MD5 90bbab9a19782b09b5223831f9508f82 files/codasrv 701
+MD5 6755032efb635644da35529df4a14fc4 files/coda-update 1028
+MD5 57df6707d5f1b86d0abe86b165a05355 files/auth2 857
+MD5 d08316a08429d573d30dbc9924707206 files/digest-coda-6.0.3 63
+MD5 d21e4e5142a0266459b5ad8b39e3e707 files/coda-6.0.3-iowr.patch 607
diff --git a/net-fs/coda/coda-6.0.3.ebuild b/net-fs/coda/coda-6.0.3.ebuild
new file mode 100644
index 000000000000..2f14b48a7567
--- /dev/null
+++ b/net-fs/coda/coda-6.0.3.ebuild
@@ -0,0 +1,119 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/coda/coda-6.0.3.ebuild,v 1.1 2004/03/23 20:18:49 dragonheart Exp $
+
+IUSE="kerberos"
+
+DESCRIPTION="Coda is an advanced networked filesystem developed at Carnegie Mellon Univ."
+HOMEPAGE="http://www.coda.cs.cmu.edu"
+SRC_URI="ftp://ftp.coda.cs.cmu.edu/pub/coda/src/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~x86"
+
+# partly based on the deps suggested by Mandrake's RPM, and/or on my current versions
+# Also, definely needs coda.h from linux-headers.
+DEPEND=">=sys-apps/portage-2.0.47-r10
+ >=sys-libs/lwp-1.10
+ >=net-libs/rpc2-1.20
+ >=sys-libs/rvm-1.8
+ >=sys-libs/db-3
+ >=sys-libs/ncurses-4
+ >=sys-libs/readline-3
+ >=sys-kernel/linux-headers-2.4
+ >=dev-lang/perl-5.8
+ kerberos? ( virtual/krb5 )"
+
+# >=sys-apps/sed-4
+# net-fs/coda-kernel
+
+
+RDEPEND=">=sys-libs/lwp-1.10
+ >=net-libs/rpc2-1.20
+ >=sys-libs/rvm-1.8
+ >=sys-libs/db-3
+ >=sys-libs/ncurses-4
+ >=sys-libs/readline-3
+ kerberos? ( virtual/krb5 )"
+
+
+
+
+src_unpack() {
+ unpack ${A}
+ epatch ${FILESDIR}/coda-6.0.3-iowr.patch
+}
+
+src_compile() {
+ local myflags=""
+
+ use kerberos && myflags="${myflags} --with-crypto"
+
+ econf ${myflags} || die "configure failed"
+ emake -j1 || die "emake failed"
+}
+
+src_install () {
+ #these crazy makefiles dont seem to use DESTDIR, but they do use these...
+ # (except infodir, but no harm in leaving it there)
+ # see Makeconf.setup in the package
+
+ #Also note that for Coda, we need to do "make client-install" for
+ # the client, and "make server-install" for the server.
+ #...you can find out about this from ./configs/Makerules
+ emake \
+ CINIT-SCRIPTS="" \
+ prefix=${D}/usr \
+ sysconfdir=${D}/etc/coda \
+ mandir=${D}/usr/share/man \
+ infodir=${D}/usr/share/info \
+ oldincludedir=${D}/usr/include client-install || die
+
+ emake \
+ SINIT-SCRIPTS="" \
+ prefix=${D}/usr \
+ sysconfdir=${D}/etc/coda \
+ mandir=${D}/usr/share/man \
+ oldincludedir=${D}/usr/include server-install || die
+ infodir=${D}/usr/share/info \
+
+ dodoc README* ChangeLog CREDITS LICENSE
+
+ exeinto /etc/init.d
+ doexe ${FILESDIR}/venus
+ doexe ${FILESDIR}/coda-update
+ doexe ${FILESDIR}/codasrv
+ doexe ${FILESDIR}/auth2
+
+ # We may use a conf.d/coda file at some point ?
+# insinto /etc/conf.d
+# newins ${FILESDIR}/coda.conf.d coda
+
+ # I am not sure why coda misplaces this file...
+ mv -f ${D}/etc/server.conf.ex ${D}/etc/coda/server.conf.ex
+
+ sed -i -e "s,^#vicedir=/.*,vicedir=/var/lib/vice," \
+ ${D}/etc/coda/server.conf.ex
+
+ sed -i -e "s,^#mountpoint=/.*,mountpoint=/mnt/coda," \
+ ${D}/etc/coda/venus.conf.ex
+
+ dodir /var/lib/vice
+ dodir /mnt/coda
+ dodir /usr/coda
+ dodir /usr/coda/spool
+
+ diropts -m0700
+ dodir /usr/coda/etc
+ dodir /usr/coda/venus.cache
+}
+
+pkg_postinst () {
+ einfo
+ einfo "To enable the coda at boot up, please do:"
+ einfo " rc-update venus default"
+ einfo
+ einfo "* To get started, run venus-setup and vice-setup"
+ einfo
+}
diff --git a/net-fs/coda/files/auth2 b/net-fs/coda/files/auth2
new file mode 100644
index 000000000000..2b83529d4369
--- /dev/null
+++ b/net-fs/coda/files/auth2
@@ -0,0 +1,47 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/coda/files/auth2,v 1.1 2004/03/23 20:18:49 dragonheart Exp $
+
+depend() {
+ need net
+}
+
+checkconfig() {
+ if [ ! -e /var/lib/vice/hostname ] ; then
+ eerror "Please set up vice before starting the service..."
+ return 1
+ fi
+}
+
+we_are_scm() {
+ if [ "`cat /var/lib/vice/hostname`" = "`cat /var/lib/vice/db/scm`" ] ; then
+ return 0
+ else
+ return 1
+ fi
+}
+
+start() {
+ checkconfig || return 1
+
+ ebegin "Starting auth2"
+
+ # Check to see if we are the SCM. If not, we must add -chk to auth2
+
+ if (! we_are_scm) ; then
+ start-stop-daemon --start --quiet --exec /usr/sbin/auth2 \
+ --background -- -chk
+ else
+ start-stop-daemon --start --quiet --exec /usr/sbin/auth2 \
+ --background
+ fi
+
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping auth2"
+ start-stop-daemon --stop --quiet --exec /usr/sbin/auth2
+ eend $?
+}
diff --git a/net-fs/coda/files/coda-6.0.3-iowr.patch b/net-fs/coda/files/coda-6.0.3-iowr.patch
new file mode 100644
index 000000000000..f7f374c17051
--- /dev/null
+++ b/net-fs/coda/files/coda-6.0.3-iowr.patch
@@ -0,0 +1,12 @@
+diff -ru coda-6.0.3.orig/lib-src/kernel-includes/coda.h coda-6.0.3/lib-src/kernel-includes/coda.h
+--- coda-6.0.3.orig/lib-src/kernel-includes/coda.h 2003-05-24 03:57:52.000000000 +0930
++++ coda-6.0.3/lib-src/kernel-includes/coda.h 2004-02-13 20:57:57.012548016 +0930
+@@ -311,7 +311,7 @@
+ #define VC_MAXMSGSIZE sizeof(union inputArgs)+sizeof(union outputArgs) +\
+ VC_MAXDATASIZE
+
+-#define CIOC_KERNEL_VERSION _IOWR('c', 10, sizeof (int))
++#define CIOC_KERNEL_VERSION _IOWR('c', 10, int)
+
+ #if 0
+ #define CODA_KERNEL_VERSION 0 /* don't care about kernel version number */
diff --git a/net-fs/coda/files/coda-update b/net-fs/coda/files/coda-update
new file mode 100644
index 000000000000..e82f4349ca18
--- /dev/null
+++ b/net-fs/coda/files/coda-update
@@ -0,0 +1,52 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/coda/files/coda-update,v 1.1 2004/03/23 20:18:49 dragonheart Exp $
+
+depend() {
+ need net auth2
+}
+
+we_are_scm() {
+ if [ "`cat /var/lib/vice/hostname`" = "`cat /var/lib/vice/db/scm`" ] ; then
+ return 0
+ else
+ return 1
+ fi
+}
+
+checkconfig() {
+ if [ ! -e /var/lib/vice/hostname ] ; then
+ eerror "Please set up coda before starting the service..."
+ return 1
+ fi
+}
+
+start() {
+ checkconfig || return 1
+
+ ebegin "Starting coda update servers"
+
+ # Check to see if we are the SCM.
+ if we_are_scm ; then
+ start-stop-daemon --start --quiet --exec /usr/sbin/rpc2portmap
+ start-stop-daemon --start --quiet --exec /usr/sbin/updatesrv
+ fi
+
+ start-stop-daemon --start --quiet --exec /usr/sbin/updateclnt
+
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping coda-update"
+
+ if we_are_scm ; then
+ start-stop-daemon --stop --quiet --exec /usr/sbin/rpc2portmap
+ start-stop-daemon --stop --quiet --exec /usr/sbin/updatesrv
+ fi
+
+ start-stop-daemon --stop --quiet --exec /usr/sbin/updateclnt
+
+ eend $?
+}
diff --git a/net-fs/coda/files/codasrv b/net-fs/coda/files/codasrv
new file mode 100644
index 000000000000..6c4dcf4cb64a
--- /dev/null
+++ b/net-fs/coda/files/codasrv
@@ -0,0 +1,39 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/coda/files/codasrv,v 1.1 2004/03/23 20:18:49 dragonheart Exp $
+
+depend() {
+ need net coda-update auth2
+}
+
+checkconfig() {
+ if [ ! -e /var/lib/vice/hostname ] ; then
+ eerror "Please set up vice before starting the service..."
+ return 1
+ fi
+}
+
+we_are_scm() {
+ if [ "`cat /var/lib/vice/hostname`" = "`cat /var/lib/vice/db/scm`" ] ; then
+ return 0
+ else
+ return 1
+ fi
+}
+
+start() {
+ checkconfig || return 1
+
+ ebegin "Starting codasrv"
+ start-stop-daemon --start --exec /usr/sbin/codasrv
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping codasrv"
+ start-stop-daemon --stop --quiet --exec /usr/sbin/codasrv
+ /usr/sbin/volutil shutdown
+ sleep 30
+ eend $?
+}
diff --git a/net-fs/coda/files/digest-coda-6.0.3 b/net-fs/coda/files/digest-coda-6.0.3
new file mode 100644
index 000000000000..708ec8699bf4
--- /dev/null
+++ b/net-fs/coda/files/digest-coda-6.0.3
@@ -0,0 +1 @@
+MD5 86af6c30582724a9899e39791a20435f coda-6.0.3.tar.gz 1488634
diff --git a/net-fs/coda/files/venus b/net-fs/coda/files/venus
new file mode 100644
index 000000000000..220f902824a9
--- /dev/null
+++ b/net-fs/coda/files/venus
@@ -0,0 +1,30 @@
+#!/sbin/runscript
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-fs/coda/files/venus,v 1.1 2004/03/23 20:18:49 dragonheart Exp $
+
+depend() {
+ need net codasrv
+}
+
+checkconfig() {
+ if [ ! -e /var/lib/vice/hostname ] ; then
+ eerror "Please set up vice before starting the service..."
+ return 1
+ fi
+}
+
+start() {
+ checkconfig || return 1
+
+ ebegin "Starting venus"
+ start-stop-daemon --start --quiet --exec /usr/sbin/venus --background
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping venus"
+ start-stop-daemon --stop --quiet --exec /usr/sbin/venus
+ umount -l /mnt/coda &>/dev/null
+ eend $?
+}
diff --git a/net-fs/coda/metadata.xml b/net-fs/coda/metadata.xml
new file mode 100644
index 000000000000..bbb117a5aac6
--- /dev/null
+++ b/net-fs/coda/metadata.xml
@@ -0,0 +1,10 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<herd>no-herd</herd>
+<maintainer>
+ <email>dragonheart@gentoo.org</email>
+ <name>Daniel Black</name>
+ <description>probably volunteered when I shouldn't off</description>
+</maintainer>
+</pkgmetadata>