summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-dns/noip-updater/noip-updater-2.1.4-r1.ebuild')
-rw-r--r--net-dns/noip-updater/noip-updater-2.1.4-r1.ebuild59
1 files changed, 0 insertions, 59 deletions
diff --git a/net-dns/noip-updater/noip-updater-2.1.4-r1.ebuild b/net-dns/noip-updater/noip-updater-2.1.4-r1.ebuild
deleted file mode 100644
index e4ef4a2e0428..000000000000
--- a/net-dns/noip-updater/noip-updater-2.1.4-r1.ebuild
+++ /dev/null
@@ -1,59 +0,0 @@
-# Copyright 1999-2007 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/net-dns/noip-updater/noip-updater-2.1.4-r1.ebuild,v 1.1 2007/07/26 11:29:54 uberlord Exp $
-
-inherit eutils toolchain-funcs
-
-IUSE=""
-
-MY_P=${P/-updater/}
-S=${WORKDIR}/${MY_P}
-DESCRIPTION="no-ip.com dynamic DNS updater"
-HOMEPAGE="http://www.no-ip.com"
-SRC_URI="http://www.no-ip.com/client/linux/${MY_P}.tar.gz"
-
-SLOT="0"
-LICENSE="GPL-2"
-KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86"
-
-RDEPEND="virtual/libc"
-
-DEPEND="${RDEPEND} sys-devel/gcc"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- epatch "${FILESDIR}"/noip-2.1.3-cflags.patch
- epatch "${FILESDIR}"/noip-2.1.4-daemon.patch
- sed -i \
- -e "s:\(#define CONFIG_FILEPATH\).*:\1 \"/etc\":" \
- -e "s:\(#define CONFIG_FILENAME\).*:\1 \"/etc/no-ip2.conf\":" \
- noip2.c || die
-}
-
-src_compile() {
- emake \
- CC=$(tc-getCC) \
- PREFIX=/usr \
- CONFDIR=/etc || die
-}
-
-src_install() {
- into /usr
- dosbin noip2
- dodoc README.FIRST COPYING
- newinitd "${FILESDIR}"/noip2.start noip
-}
-
-pkg_postinst() {
- elog "Configuration can be done manually via:"
- elog "/usr/sbin/noip2 -C or "
- elog "first time you use the /etc/init.d/noip script; or"
- elog "by using this ebuild's config option."
-}
-
-pkg_config() {
- cd /tmp
- einfo "Answer the following questions."
- noip2 -C || die
-}