summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'net-dialup/fcpci')
-rw-r--r--net-dialup/fcpci/ChangeLog10
-rw-r--r--net-dialup/fcpci/fcpci-0.1.ebuild51
-rw-r--r--net-dialup/fcpci/files/digest-fcpci-0.13
-rw-r--r--net-dialup/fcpci/metadata.xml6
4 files changed, 67 insertions, 3 deletions
diff --git a/net-dialup/fcpci/ChangeLog b/net-dialup/fcpci/ChangeLog
index ec1ba86b4dcf..e0222cc002ab 100644
--- a/net-dialup/fcpci/ChangeLog
+++ b/net-dialup/fcpci/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for net-dialup/fcpci
-# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/net-dialup/fcpci/ChangeLog,v 1.16 2006/03/12 11:40:20 mrness Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/fcpci/ChangeLog,v 1.17 2008/01/06 01:53:01 sbriesen Exp $
+
+*fcpci-0.1 (06 Jan 2008)
+
+ 06 Jan 2008; Stefan Briesenick <sbriesen@gentoo.org> metadata.xml,
+ +fcpci-0.1.ebuild:
+ using special openSUSE repository for AVM drivers from now on.
12 Mar 2006; Alin Nastac <mrness@gentoo.org> fcpci-3.11.02-r2.ebuild:
Quote $WORKDIR.
diff --git a/net-dialup/fcpci/fcpci-0.1.ebuild b/net-dialup/fcpci/fcpci-0.1.ebuild
new file mode 100644
index 000000000000..94a5c1ceaa07
--- /dev/null
+++ b/net-dialup/fcpci/fcpci-0.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/net-dialup/fcpci/fcpci-0.1.ebuild,v 1.1 2008/01/06 01:53:01 sbriesen Exp $
+
+inherit eutils rpm linux-mod
+
+DESCRIPTION="AVM kernel 2.6 modules for Fritz!Card PCI"
+HOMEPAGE="http://opensuse.foehr-it.de/"
+SRC_URI="http://opensuse.foehr-it.de/rpms/10_3/src/${P}-0.src.rpm"
+
+LICENSE="AVM-FC"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="!net-dialup/fritzcapi"
+RDEPEND="${DEPEND} net-dialup/capi4k-utils"
+
+S="${WORKDIR}/fritz"
+
+pkg_setup() {
+ linux-mod_pkg_setup
+
+ if ! kernel_is 2 6; then
+ die "This package works only with 2.6 kernel!"
+ fi
+
+ BUILD_TARGETS="all"
+ BUILD_PARAMS="KDIR=${KV_DIR} LIBDIR=${S}/src"
+ MODULE_NAMES="${PN}(net:${S}/src)"
+}
+
+src_unpack() {
+ local BIT="" PAT="01234"
+ if use amd64; then
+ BIT="64bit-" PAT="1234"
+ fi
+
+ rpm_unpack "${DISTDIR}/${A}" || die "failed to unpack ${A} file"
+ DISTDIR="${WORKDIR}" unpack ${PN}-suse[0-9][0-9]-${BIT}[0-9].[0-9]*-[0-9]*.tar.gz
+
+ cd "${S}"
+ epatch $(sed -n "s|^Patch[${PAT}]:\s*\(.*\)|../\1|p" ../${PN}.spec)
+ convert_to_m "src/Makefile"
+}
+
+src_install() {
+ linux-mod_src_install
+ dodoc CAPI*.txt
+ dohtml *.html
+}
diff --git a/net-dialup/fcpci/files/digest-fcpci-0.1 b/net-dialup/fcpci/files/digest-fcpci-0.1
new file mode 100644
index 000000000000..8ea388c05cdf
--- /dev/null
+++ b/net-dialup/fcpci/files/digest-fcpci-0.1
@@ -0,0 +1,3 @@
+MD5 6347f341489383ea543c302c0b8cd230 fcpci-0.1-0.src.rpm 1418928
+RMD160 b74bc1e9acaa38c4366951a6c2b41387ba7a0bd8 fcpci-0.1-0.src.rpm 1418928
+SHA256 72588c1efaf4572ca8dbf3c53b0a3e496518d042f004db29764af2777677a485 fcpci-0.1-0.src.rpm 1418928
diff --git a/net-dialup/fcpci/metadata.xml b/net-dialup/fcpci/metadata.xml
index 1e11e7bbd01b..5c648b8ae7af 100644
--- a/net-dialup/fcpci/metadata.xml
+++ b/net-dialup/fcpci/metadata.xml
@@ -1,5 +1,9 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
-<herd>net-dialup</herd>
+ <herd>net-dialup</herd>
+ <maintainer>
+ <email>sbriesen@gentoo.org</email>
+ <name>Stefan Briesenick</name>
+ </maintainer>
</pkgmetadata>