summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-video')
-rw-r--r--media-video/dvdstyler/ChangeLog9
-rw-r--r--media-video/dvdstyler/dvdstyler-1.7.2.ebuild53
-rw-r--r--media-video/dvdstyler/dvdstyler-1.7.2_beta4.ebuild4
-rw-r--r--media-video/dvdstyler/files/dvdstyler-1.7.2-skipxmlvalidation.patch11
4 files changed, 74 insertions, 3 deletions
diff --git a/media-video/dvdstyler/ChangeLog b/media-video/dvdstyler/ChangeLog
index 3c0aa7fd21c2..ac859016c623 100644
--- a/media-video/dvdstyler/ChangeLog
+++ b/media-video/dvdstyler/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for media-video/dvdstyler
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/dvdstyler/ChangeLog,v 1.34 2009/02/16 06:57:02 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/dvdstyler/ChangeLog,v 1.35 2009/04/29 01:31:23 dragonheart Exp $
+
+*dvdstyler-1.7.2 (29 Apr 2009)
+
+ 29 Apr 2009; Daniel Black <dragonheart@gentoo.org>
+ +files/dvdstyler-1.7.2-skipxmlvalidation.patch,
+ dvdstyler-1.7.2_beta4.ebuild, +dvdstyler-1.7.2.ebuild:
+ version bug as per bug #262454. Ebuild changes thanks to Fabio
16 Feb 2009; Daniel Black <dragonheart@gentoo.org>
-dvdstyler-1.5-r1.ebuild, -dvdstyler-1.5.1.ebuild,
diff --git a/media-video/dvdstyler/dvdstyler-1.7.2.ebuild b/media-video/dvdstyler/dvdstyler-1.7.2.ebuild
new file mode 100644
index 000000000000..a43e9987dc86
--- /dev/null
+++ b/media-video/dvdstyler/dvdstyler-1.7.2.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-video/dvdstyler/dvdstyler-1.7.2.ebuild,v 1.1 2009/04/29 01:31:23 dragonheart Exp $
+
+EAPI=2
+inherit eutils wxwidgets autotools
+
+#MY_P=DVDStyler-${PV/_beta/b}_1
+MY_P=DVDStyler-${PV}
+
+DESCRIPTION="DVDStyler is a cross-platform DVD authoring System"
+HOMEPAGE="http://www.dvdstyler.de"
+SRC_URI="mirror://sourceforge/dvdstyler/${MY_P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="gnome"
+
+COMMON_DEPEND="
+ >=media-video/ffmpeg-0.4.9_p20090201[encode]
+ x11-libs/wxGTK:2.8
+ >=media-libs/wxsvg-1.0[ffmpeg]
+ >=media-libs/libexif-0.6.16
+ gnome? ( >=gnome-base/libgnomeui-2.0 )"
+RDEPEND="${COMMON_DEPEND}
+ virtual/cdrtools
+ >=media-video/dvdauthor-0.6.14
+ >=app-cdr/dvd+rw-tools-7.1
+ >=app-cdr/dvdisaster-0.71.0"
+DEPEND="${COMMON_DEPEND}
+ dev-util/pkgconfig
+ >=sys-devel/gettext-0.17"
+
+S="${WORKDIR}"/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}/dvdstyler-1.7.2-skipxmlvalidation.patch"
+ eautomake
+}
+
+src_configure() {
+ export WX_GTK_VER="2.8"
+ need-wxwidgets gtk2
+ myconf="${myconf} --with-wx-config=${WX_CONFIG}"
+ econf ${myconf}
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "failed to install"
+ rm "${D}"usr/share/doc/${PN}/COPYING "${D}"usr/share/doc/${PN}/INSTALL
+ mv "${D}"usr/share/doc/${PN} "${D}"usr/share/doc/${PF}
+}
diff --git a/media-video/dvdstyler/dvdstyler-1.7.2_beta4.ebuild b/media-video/dvdstyler/dvdstyler-1.7.2_beta4.ebuild
index c521eb117d05..272f686c0b73 100644
--- a/media-video/dvdstyler/dvdstyler-1.7.2_beta4.ebuild
+++ b/media-video/dvdstyler/dvdstyler-1.7.2_beta4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-video/dvdstyler/dvdstyler-1.7.2_beta4.ebuild,v 1.2 2009/02/16 06:57:02 dragonheart Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-video/dvdstyler/dvdstyler-1.7.2_beta4.ebuild,v 1.3 2009/04/29 01:31:23 dragonheart Exp $
EAPI=2
inherit eutils wxwidgets
@@ -28,7 +28,7 @@ RDEPEND="${COMMON_DEPEND}
>=app-cdr/dvd+rw-tools-7.1
>=app-cdr/dvdisaster-0.71.0"
# >=media-video/dvdauthor-0.6.16
-DEPEND="${COMMON_DEEND}
+DEPEND="${COMMON_DEPEND}
dev-util/pkgconfig
>=sys-devel/gettext-0.17"
diff --git a/media-video/dvdstyler/files/dvdstyler-1.7.2-skipxmlvalidation.patch b/media-video/dvdstyler/files/dvdstyler-1.7.2-skipxmlvalidation.patch
new file mode 100644
index 000000000000..b13681dcfea0
--- /dev/null
+++ b/media-video/dvdstyler/files/dvdstyler-1.7.2-skipxmlvalidation.patch
@@ -0,0 +1,11 @@
+--- docs/Makefile.am.old 2009-03-19 14:12:11.000000000 -0500
++++ docs/Makefile.am 2009-03-19 14:12:35.000000000 -0500
+@@ -371,7 +371,7 @@
+
+ help.zip: DVDStylerGuide.xml
+ mkdir temp
+- (cd temp && $(XMLTO) htmlhelp ../DVDStylerGuide.xml && cp ../htmlhelp.hhp ../toc.hhc ../index.html . && $(ZIP) ../help.zip *.html htmlhelp.hhp toc.hhc)
++ (cd temp && $(XMLTO) --skip-validation htmlhelp ../DVDStylerGuide.xml && cp ../htmlhelp.hhp ../toc.hhc ../index.html . && $(ZIP) ../help.zip *.html htmlhelp.hhp toc.hhc)
+ rm -f temp/*.html temp/*.hh*
+ rmdir temp
+ # Tell versions [3.59,3.63) of GNU make to not export all variables.