summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-sound/lastfm-desktop/lastfm-desktop-2.1.35.ebuild')
-rw-r--r--media-sound/lastfm-desktop/lastfm-desktop-2.1.35.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/media-sound/lastfm-desktop/lastfm-desktop-2.1.35.ebuild b/media-sound/lastfm-desktop/lastfm-desktop-2.1.35.ebuild
new file mode 100644
index 000000000000..50e9d7c92f85
--- /dev/null
+++ b/media-sound/lastfm-desktop/lastfm-desktop-2.1.35.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/media-sound/lastfm-desktop/lastfm-desktop-2.1.35.ebuild,v 1.1 2013/08/14 10:00:29 jlec Exp $
+
+EAPI=5
+
+inherit qt4-r2
+
+DESCRIPTION="The official Last.fm desktop application suite"
+HOMEPAGE="http://www.last.fm https://github.com/lastfm/lastfm-desktop"
+SRC_URI="https://github.com/lastfm/lastfm-desktop/archive/2.1.35.tar.gz -> ${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-3"
+KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
+IUSE=""
+
+RDEPEND="
+ dev-qt/qtcore:4
+ dev-qt/qtdbus:4
+ dev-qt/qtgui:4
+ dev-qt/qtphonon:4
+ dev-qt/qtsql:4
+ dev-qt/qtwebkit:4
+ media-libs/libgpod
+ media-libs/liblastfm
+ sys-libs/zlib
+"
+DEPEND="${RDEPEND}
+"
+
+src_configure() {
+ eqmake4 Last.fm.pro PREFIX="${EPREFIX}"/usr
+}