summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs')
-rw-r--r--media-libs/alsa-lib/alsa-lib-0.5.9.ebuild33
-rw-r--r--media-libs/alsa-lib/files/digest-alsa-lib-0.5.91
-rw-r--r--media-libs/avifile/avifile-0.48.ebuild90
-rw-r--r--media-libs/avifile/avifile-0.49.ebuild96
-rw-r--r--media-libs/avifile/files/capproc.cpp469
-rw-r--r--media-libs/avifile/files/digest-avifile-0.482
-rw-r--r--media-libs/avifile/files/digest-avifile-0.492
-rw-r--r--media-libs/libsdl/files/digest-libsdl-1.1.51
-rw-r--r--media-libs/libsdl/libsdl-1.1.5.ebuild44
-rw-r--r--media-libs/libungif/files/digest-libungif-4.1.0_beta1-r11
-rw-r--r--media-libs/libungif/libungif-4.1.0_beta1-r1.ebuild32
-rw-r--r--media-libs/mesa-glu/mesa-glu-3.2.1.ebuild39
-rw-r--r--media-libs/mesa/files/digest-mesa-glu-3.2.11
-rw-r--r--media-libs/mesa/files/digest-mesa-glu-3.41
-rw-r--r--media-libs/mesa/mesa-glu-3.2.1.ebuild39
-rw-r--r--media-libs/mesa/mesa-glu-3.4.ebuild40
-rw-r--r--media-libs/mpeg2vidcodec/files/digest-mpeg2vidcodec-121
-rw-r--r--media-libs/mpeg2vidcodec/mpeg2vidcodec-12.ebuild39
18 files changed, 0 insertions, 931 deletions
diff --git a/media-libs/alsa-lib/alsa-lib-0.5.9.ebuild b/media-libs/alsa-lib/alsa-lib-0.5.9.ebuild
deleted file mode 100644
index 088b2a617856..000000000000
--- a/media-libs/alsa-lib/alsa-lib-0.5.9.ebuild
+++ /dev/null
@@ -1,33 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/media-libs/alsa-lib/alsa-lib-0.5.9.ebuild,v 1.4 2000/11/09 19:57:10 drobbins Exp $
-
-P=alsa-lib-0.5.9
-A=${P}.tar.bz2
-S=${WORKDIR}/${P}
-DESCRIPTION="Advanced Linux Sound Architecture / Library"
-SRC_URI="ftp://ftp.alsa-project.org/pub/lib/"${A}
-HOMEPAGE="http://www.alsa-project.org/"
-
-DEPEND=">=sys-libs/glibc-2.1.3"
-
-src_unpack() {
- unpack ${A}
-}
-
-src_compile() {
- cd ${S}
- try ./configure --host=${CHOST} --prefix=/usr
- try make
-}
-
-src_install() {
- cd ${S}
- try make DESTDIR=${D} install
- dodoc ChangeLog COPYING
-}
-
-
-
-
diff --git a/media-libs/alsa-lib/files/digest-alsa-lib-0.5.9 b/media-libs/alsa-lib/files/digest-alsa-lib-0.5.9
deleted file mode 100644
index e64ddb82e100..000000000000
--- a/media-libs/alsa-lib/files/digest-alsa-lib-0.5.9
+++ /dev/null
@@ -1 +0,0 @@
-MD5 7c05d056cd95c481387fcd0378aed0d8 alsa-lib-0.5.9.tar.bz2
diff --git a/media-libs/avifile/avifile-0.48.ebuild b/media-libs/avifile/avifile-0.48.ebuild
deleted file mode 100644
index 6d3884612c6d..000000000000
--- a/media-libs/avifile/avifile-0.48.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/media-libs/avifile/avifile-0.48.ebuild,v 1.2 2000/11/07 11:16:08 achim Exp $
-
-A="${P}.tar.gz binaries.zip"
-S=${WORKDIR}/${P}
-DESCRIPTION="Library for AVI-Files"
-SRC_URI="ftp://ftp.e1.bmstu.ru/pub/devtools/SDL/AVI/${P}.tar.gz
- ftp://ftp.e1.bmstu.ru/pub/devtools/SDL/AVI/binaries.zip"
-
-HOMEPAGE="http://divx.euro.ru/"
-
-DEPEND=">=kde-base/qt-x11-2.1.1
- >=media-video/xmps-0.1.3"
-RDEPEND=">=kde-base/qt-x11-2.1.1
- >=media-libs/libsdl-1.1.5
- >=x11-libs/gtk+-1.2.8
- >=media-sound/esound-0.2.19"
-
-src_unpack () {
-
- WIN32=/usr/libexec/avifile/win32
-
- unpack ${P}.tar.gz
-
- cd ${S}
-
- cp configure configure.orig
- sed -e "s:/usr/lib/win32:$WIN32:" configure.orig > configure
-
-
- cd ${S}/lib/loader
-
- cp elfdll.c elfdll.c.orig
- sed -e "s:/usr/lib/win32:$WIN32:" elfdll.c.orig > elfdll.c
-
- cd ../audiodecoder
-
- cp audiodecoder.cpp audiodecoder.cpp.orig
- sed -e "s:/usr/lib/win32:$WIN32:" audiodecoder.cpp.orig > audiodecoder.cpp
-
- cd ${S}/player
-
- cp mywidget.cpp mywidget.cpp.orig
- sed -e "s:/usr/lib/win32:$WIN32:" mywidget.cpp.orig > mywidget.cpp
-
- cp ${FILESDIR}/capproc.cpp ${S}/samples/qtvidcap
-
-}
-
-src_compile() {
-
- cd ${S}
- try ./configure --prefix=/usr/X11R6 --host=${CHOST}
- cp Makefile Makefile.orig
- sed -e "s:/usr/libexec/avifile/win32:${D}/usr/libexec/avifile/win32:" \
- Makefile.orig > Makefile
- try make
- cd xmps-avi-plugin
- try make
-
-}
-
-src_install () {
-
- cd ${S}
- dodir /usr/X11R6/lib /usr/X11R6/bin
- dodir /usr/libexec/avifile/win32
-
- make prefix=${D}/usr/X11R6 install
-
- cd xmps-avi-plugin
- insinto /usr/X11R6/lib/xmps/Codecs
- insopts -m755
- doins libavi.so
-
-
- cd ${D}/usr/libexec/avifile/win32
- unzip ${DISTDIR}/binaries.zip
- cd ${S}
- dodoc COPYING README
- cd doc
- dodoc CREDITS EXCEPTIONS FreeBSD LICENSING TODO
- dodoc VIDEO-PERFORMANCE WARNINGS
-}
-
-
-
-
diff --git a/media-libs/avifile/avifile-0.49.ebuild b/media-libs/avifile/avifile-0.49.ebuild
deleted file mode 100644
index c119bed9b1de..000000000000
--- a/media-libs/avifile/avifile-0.49.ebuild
+++ /dev/null
@@ -1,96 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/media-libs/avifile/avifile-0.49.ebuild,v 1.1 2000/11/15 22:52:34 achim Exp $
-
-A="${P}.tar.gz binaries.zip"
-S=${WORKDIR}/${P}
-DESCRIPTION="Library for AVI-Files"
-SRC_URI="http://divx.euro.ru/${P}.tar.gz
- http://divx.euro.ru/binaries.zip"
-
-HOMEPAGE="http://divx.euro.ru/"
-
-DEPEND=">=kde-base/qt-x11-2.1.1
- >=media-video/xmps-0.1.3"
-RDEPEND=">=kde-base/qt-x11-2.1.1
- >=media-libs/libsdl-1.1.5
- >=x11-libs/gtk+-1.2.8
- >=media-sound/esound-0.2.19"
-
-src_unpack () {
-
- WIN32=/usr/libexec/avifile/win32
-
- unpack ${P}.tar.gz
-
- cd ${S}
-
- cp configure configure.orig
- sed -e "s:/usr/lib/win32:$WIN32:" configure.orig > configure
-
-
- cd ${S}/lib/loader
-
- cp elfdll.c elfdll.c.orig
- sed -e "s:/usr/lib/win32:$WIN32:" elfdll.c.orig > elfdll.c
-
- cd ../audiodecoder
-
- cp audiodecoder.cpp audiodecoder.cpp.orig
- sed -e "s:/usr/lib/win32:$WIN32:" audiodecoder.cpp.orig > audiodecoder.cpp
-
- cd ${S}/player
-
- cp mywidget.cpp mywidget.cpp.orig
- sed -e "s:/usr/lib/win32:$WIN32:" mywidget.cpp.orig > mywidget.cpp
-
-# cp ${FILESDIR}/capproc.cpp ${S}/samples/qtvidcap
- cd ${S}/xmps-avi-plugin
-
- cp avi_codec.cpp avi_codec.cpp.orig
- sed -e "s:drawfunc(char\* data):drawfunc(void\* data):" \
- avi_codec.cpp.orig > avi_codec.cpp
-
-}
-
-src_compile() {
-
- cd ${S}
- try ./configure --prefix=/usr/X11R6 --host=${CHOST}
- cp Makefile Makefile.orig
- sed -e "s:/usr/libexec/avifile/win32:${D}/usr/libexec/avifile/win32:" \
- Makefile.orig > Makefile
- try make
- cd xmps-avi-plugin
- try make
-
-}
-
-src_install () {
-
- cd ${S}
- dodir /usr/X11R6/lib /usr/X11R6/bin
- dodir /usr/libexec/avifile/win32
-
- make prefix=${D}/usr/X11R6 install
-
- cd xmps-avi-plugin
- insinto /usr/X11R6/lib/xmps/Codecs
- insopts -m755
- doins libavi.so
-
-
- cd ${D}/usr/libexec/avifile/win32
- unzip ${DISTDIR}/binaries.zip
- cd ${S}
- dodoc COPYING README
- cd doc
- dodoc CREDITS EXCEPTIONS FreeBSD LICENSING TODO
- dodoc VIDEO-PERFORMANCE WARNINGS
-}
-
-
-
-
-
diff --git a/media-libs/avifile/files/capproc.cpp b/media-libs/avifile/files/capproc.cpp
deleted file mode 100644
index 264fe4c95d81..000000000000
--- a/media-libs/avifile/files/capproc.cpp
+++ /dev/null
@@ -1,469 +0,0 @@
-#include "capproc.h"
-#include "dsp.h"
-#include <unistd.h>
-#include <avifile.h>
-#include <videoencoder.h>
-#include <aviutil.h>
-
-#define __MODULE__ "Capture Process"
-class frame_allocator
-{
- struct frame
- {
- char* data;
- int status;
- };
- int _w;
- int _h;
- vector<frame> frames;
- int _limit;
- int refs;
-public:
- frame_allocator(int w, int h, int limit):_w(w), _h(h), _limit(limit),refs(2){}
- void release()
- {
- refs--;
- if(!refs)delete this;
- }
- char* alloc()
- {
- int i;
- for(i=0; i<frames.size(); i++)
- {
- if(frames[i].status==0)
- {
- frames[i].status=1;
- *(int*)(frames[i].data)=i;
- return frames[i].data+4;
- }
- }
- if(frames.size()>=_limit)return 0;
- frame f;
- f.data=new char[_w*_h*3+4];
- f.status=1;
- frames.push_back(f);
- *(int*)(f.data)=i;
- return f.data+4;
- }
- void free(char* mem)
- {
- if(!mem)
- {
- cerr<<"ERROR: Freeing 0!"<<endl;
- return;
- }
- int id=*(int*)(mem-4);
- if((id<0)||(id>=frames.size())||(frames[id].data!=(mem-4)))
- {
- cerr<<"ERROR: Freeing unknown memory!"<<endl;
- return;
- }
- if(frames[id].status==0)
- {
- cerr<<"ERROR: Duplicate free()!"<<endl;
- return;
- }
- frames[id].status=0;
- }
- ~frame_allocator()
- {
- for(int i=0; i<frames.size(); i++)
- delete frames[i].data;
- }
-};
-static frame_allocator* allocator2=0;
-void* CaptureProcess::vidcap(void* arg)
-{
- CaptureProcess& a=*(CaptureProcess*)arg;
- int w=a.res_w;
- int h=a.res_h;
- const float fps=a.fps;
-// char tmpframe[384*288*4];
- a.m_v4l->grabSetParams(1, &w, &h, VIDEO_PALETTE_RGB24);
- long long& inittime=a.starttime;
- int& cnt=a.cnt;
- int& drop=a.cap_drop;
- cnt=0;
- drop=0;
- allocator2=new frame_allocator(w,h,50);
- while(!a.m_quit)
- {
- int t1,t2,t3;
- long long currenttime=longcount();
- char* z=0;
-// cerr<<currenttime<<" "<<inittime<<" "<<fps<<endl;
-// cerr<<to_float(currenttime, inittime)*fps<<" "<<cnt<<endl;
-// double freq=550000.;
- double dist=double(currenttime-inittime)/(freq*1000.);
-// double dist=to_float(currenttime, inittime);
-// cerr<<dist<<" "<<freq<<endl;
- if(dist*fps<cnt)
- {
- usleep(10000);
-// cerr<<"Sleeping"<<endl;
- continue;
- }
- chunk ch;
- if(dist*fps<(cnt+1))
- {
- z=a.m_v4l->grabCapture(false);
-// char* tmpframe=new char[w*h*3];
- char* tmpframe=allocator2->alloc();
- int bpl=3*w;
- if(tmpframe)
- for(int i=0; i<h; i++)
- memcpy(tmpframe+i*bpl, z+(h-i-1)*bpl, bpl);
- ch.data=tmpframe;
- }
- else
- {
- ch.data=0;
- drop++;
- }
- ch.timestamp=dist;
- a.m_vidq.push(ch);
- cnt++;
-// if(cnt%100==0)
-// cerr<<"Capture thread: read "<<cnt<<" frames, dropped "<<drop<<" frames"<<endl;
- }
- allocator2->release();
- cerr<<"Capture thread exiting"<<endl;
- return 0;
-}
-int audioblock=0;
-void* CaptureProcess::audcap(void* arg)
-{
- CaptureProcess& a=*(CaptureProcess*)arg;
- dsp* thedsp=new dsp();
- if(thedsp->open(a.samplesize,a.chan,a.frequency)==0)//returns file descriptor
- return 0;
- float abps=a.samplesize*a.chan*a.frequency/8;
- char* buf=0;
- int bufsize=0;
- int blocksize=thedsp->getBufSize();
- audioblock=blocksize;
- int tim=0;
- while(!a.m_quit)
- {
-// if(buf==0)
-// {
-// buf=new char[audioblock];
-// bufsize=0;
-// }
- buf=new char[audioblock];
- memcpy(buf, thedsp->readBuf(), audioblock);
- long long ct=longcount();
- chunk ch;
- ch.data=buf;
-// double freq=550000.;
- if(a.starttime)
- ch.timestamp=double(ct-a.starttime)/(freq*1000.);
-// ch.timestamp=to_float(ct, a.starttime);
- else
- ch.timestamp=-1;
- a.m_audq.push(ch);
- bufsize+=blocksize;
- tim++;
-// if(tim%50==0)
-// cerr<<"Audio thread: read "<<float(tim*blocksize)/88200.<<" seconds"<<endl;
- if(blocksize/abps>.1)
- usleep(50000);
-// if(bufsize==audioblock)
-// {
-// a.m_audq.push(buf);
-// buf=0;
-// }
- }
-// if(buf)delete buf;
- delete thedsp;
- return 0;
-}
-void* CaptureProcess::writer(void* arg)
-{
- CaptureProcess& a=*(CaptureProcess*)arg;
- IAviWriteFile* file=0;
- IAviSegWriteFile* sfile=0;
- IVideoEncoder::SetExtendedAttr(fccIV50, "QuickCompress", 1);
- IAviVideoWriteStream* stream;
- IAviWriteStream* audioStream=0;
- BITMAPINFOHEADER bh;
-
- const double fps=a.fps;
- if(fps==0)
- throw FATAL("FPS = 0 !");
-// VideoEncoder ve;
- try
- {
- if(a.segment_size==-1)
- file=CreateIAviWriteFile(a.filename.c_str());
- else
- {
- sfile=CreateSegmentedFile(a.filename.c_str(), a.segment_size*1024LL);
- file=sfile;
- }
-// FILE* zz=fopen("bin/uncompr.bmp", "rb");
- memset(&bh, 0, sizeof(bh));
- bh.biSize=sizeof(bh);
- bh.biWidth=384;
- bh.biHeight=288;
- bh.biBitCount=24;
- bh.biSizeImage=3*384*288;
- bh.biPlanes=1;
- stream=file->AddVideoStream(a.compressor, &bh, 1000000./a.fps);
-// stream=file->AddStream(AviStream::Video);
-// ve.Init(fccIV50, (const char*)&bh);
- }
- catch(FatalError& e)
- {
- e.Print();
- a.m_quit=1;
- return 0;
- }
-
- float abps=(a.samplesize*a.frequency*a.chan)/8;
-
- WAVEFORMATEX wfm;
- wfm.wFormatTag=1;//PCM
- wfm.nChannels=a.chan;
- wfm.nSamplesPerSec=a.frequency*a.chan;
- wfm.nAvgBytesPerSec=(int)abps;
- wfm.nBlockAlign=(a.samplesize*a.chan)/8;
- wfm.wBitsPerSample=a.samplesize;
- wfm.cbSize=0;
-
-
-// ve.SetQuality(9500);
-// ve.Start();
- stream->SetQuality(a.quality);
- stream->Start();
- cerr<<"Entering loop"<<endl;
-// BITMAPINFOHEADER obh=ve.QueryOutputFormat();
-// stream->SetFormat((const char*)&obh, sizeof obh);
- int cnt=0;
- int& drop=a.comp_drop;
- long long audiodata=0LL;
- int videodata=0;
- double video_error=0;
- int hide_video=0;
- int dup_video=0;
- double snd_time, vid_time;
- drop=0;
-
- while(1)
- {
- char qq[384*288*4];
- int x1, x2;
-// char* z;
- chunk ch;
- while(a.m_vidq.size()>50)
- {
- ch=a.m_vidq.front();
- a.m_vidq.pop();
- vid_time=ch.timestamp;
- cnt++;
- if(ch.data)//delete ch.data;
- allocator2->free(ch.data);
- stream->AddFrame(0);
- videodata++;
-// stream->AddChunk(0, 0, AVIIF_KEYFRAME);
- drop++;
- }
- while((a.m_vidq.size()==0) && (a.m_audq.size()==0))
- {
- if(a.m_quit) goto finish;
- usleep(10000);
- }
- if(a.m_vidq.size())
- {
- ch=a.m_vidq.front();
- a.m_vidq.pop();
- vid_time=ch.timestamp;
- cnt++;
- if(!hide_video)
- {
- videodata++;
- stream->AddFrame(ch.data);
- if(dup_video)
- {
- videodata++;
- stream->AddFrame(ch.data);
- video_error+=1./fps;
- }
- }
- else video_error-=1./fps;
- dup_video=hide_video=0;
- if(ch.data)
- allocator2->free(ch.data);
-
- }
- if(a.m_audq.size())
- {
- if(audioStream==0)
- {
- audioStream=file->AddStream(AviStream::Audio,
- (const char*)&wfm, 18,
- 1, //uncompressed PCM data
- abps, //bytes/sec
- a.samplesize/8 //bytes/sample
- );
- }
- ch=a.m_audq.front();
- a.m_audq.pop();
-// cerr<<ch.timestamp-snd_time<<" "<<ch.timestamp-(audiodata+audioblock)/44100./2<<endl;
- snd_time=ch.timestamp;
- audioStream->AddChunk(ch.data, audioblock, AVIIF_KEYFRAME);
- audiodata+=audioblock;
- double audio_error=audiodata/abps-ch.timestamp;
- if(audio_error<video_error-5./fps)
- hide_video=1;
- if(audio_error>video_error+5./fps)
- dup_video=1;
- delete ch.data;
- }
- if(a.segment_flag && sfile)
- {
- sfile->Segment();
- a.segment_flag=0;
-// vid_clear=aud_clear=0;
- }
- if(a.timelimit!=-1)
- {
- if(snd_time>a.timelimit)
- a.m_quit=1;
- if(vid_time>a.timelimit)
- a.m_quit=1;
- }
- if(a.sizelimit!=-1)
- {
- if(file->FileSize()>a.sizelimit*1024LL)
- a.m_quit=1;
- }
- }
-finish:
- long long size=file->FileSize();
- delete file;
- allocator2->release();
- cerr<<"Write thread exiting"<<endl;
- (*a.messenger)<<"Audio: written "<<audiodata<<" bytes ( "<<audiodata/(44100.*2)<<" s )."<<endl;
- (*a.messenger)<<"Video: written "<<videodata<<" frames ( "<<videodata/fps<<" s )."<<endl;
- (*a.messenger)<<"End video pos "<<vid_time<<" s, end audio pos "<<snd_time<<" s."<<endl;
- (*a.messenger)<<"File size: "<<(size/1000)<<" Kb ( "<<size/1000/vid_time<<" Kb/s )."<<endl;
- (*a.messenger)<<"Synch fix: "<<videodata-cnt<<" frames."<<endl;
- (*a.messenger)<<"Frame drop: "<<100.*double(a.cap_drop+drop)/videodata<<"%."<<endl<<flush;
- return 0;
-}
-void CaptureProcess::Create(v4lxif* v4l,
- string filename,
- int segment_size,
- int compressor,
- int quality,
- int keyframes,
- enum Sound_Freqs frequency,
- enum Sample_Sizes samplesize,
- enum Sound_Chans chan,
- enum Resolutions res,
- int timelimit,
- int sizelimit,
- float fps)
-{
- m_v4l=v4l;
- m_quit=0;
- starttime=longcount();
-
- this->filename=filename;
- this->segment_size=segment_size;
- this->compressor=compressor;
- this->quality=quality;
- this->keyframes=keyframes;
-
- switch(frequency)
- {
- case NoAudio:
- break;
- case F44:
- this->frequency=44100;
- break;
- case F22:
- this->frequency=22050;
- break;
- case F11:
- this->frequency=11025;
- break;
- default:
- throw FATAL("Unknown frequency");
- }
- if(frequency!=NoAudio)
- {
- switch(samplesize)
- {
- case S16:
- this->samplesize=16;
- break;
- case S8:
- this->samplesize=8;
- break;
- default:
- throw FATAL("Unknown audio sample size");
- }
- switch(chan)
- {
- case Mono:
- this->chan=1;
- break;
- case Stereo:
- this->chan=2;
- break;
- default:
- throw FATAL("Unknown channel number");
- }
- }
- switch(res)
- {
- case W384:
- res_w=384;
- res_h=288;
- break;
- case W320:
- res_w=320;
- res_h=240;
- break;
- case W192:
- res_w=192;
- res_h=144;
- break;
- case W160:
- res_w=160;
- res_h=120;
- break;
- default:
- throw FATAL("Unknown video resolution");
- }
- this->timelimit=timelimit;
- this->sizelimit=sizelimit;
- this->fps=fps;
- pthread_create(&m_vidc, 0, CaptureProcess::vidcap, this);
- if(frequency!=NoAudio)
- pthread_create(&m_audc, 0, CaptureProcess::audcap, this);
- pthread_create(&m_writer, 0, CaptureProcess::writer, this);
-}
-
-CaptureProcess::~CaptureProcess()
-{
- m_quit=1;
- pthread_join(m_writer,0);
- pthread_join(m_audc,0);
- pthread_join(m_vidc,0);
- cerr<<"All threads exited"<<endl;
-// while(m_vidq.size())
-// {
-// chunk z=m_vidq.front();
-// m_vidq.pop();
-// if(z.data)delete z.data;
-// }
- while(m_audq.size())
- {
- chunk z=m_audq.front();
- m_audq.pop();
- if(z.data)delete z.data;
- }
-}
diff --git a/media-libs/avifile/files/digest-avifile-0.48 b/media-libs/avifile/files/digest-avifile-0.48
deleted file mode 100644
index 6693c747bc88..000000000000
--- a/media-libs/avifile/files/digest-avifile-0.48
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 1ef3dc746db373f34288922901577245 avifile-0.48.tar.gz
-MD5 6df7c0a266ba6e8c022160605791644b binaries.zip
diff --git a/media-libs/avifile/files/digest-avifile-0.49 b/media-libs/avifile/files/digest-avifile-0.49
deleted file mode 100644
index 176b9108cd0c..000000000000
--- a/media-libs/avifile/files/digest-avifile-0.49
+++ /dev/null
@@ -1,2 +0,0 @@
-MD5 96115ac6436b16109ce0c8d65ad3e915 avifile-0.49.tar.gz
-MD5 6df7c0a266ba6e8c022160605791644b binaries.zip
diff --git a/media-libs/libsdl/files/digest-libsdl-1.1.5 b/media-libs/libsdl/files/digest-libsdl-1.1.5
deleted file mode 100644
index ff458e021884..000000000000
--- a/media-libs/libsdl/files/digest-libsdl-1.1.5
+++ /dev/null
@@ -1 +0,0 @@
-MD5 f3e32edb188674ded00eb0b88ddd32bf SDL-1.1.5.tar.gz
diff --git a/media-libs/libsdl/libsdl-1.1.5.ebuild b/media-libs/libsdl/libsdl-1.1.5.ebuild
deleted file mode 100644
index 2c9acc8813f1..000000000000
--- a/media-libs/libsdl/libsdl-1.1.5.ebuild
+++ /dev/null
@@ -1,44 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libsdl/libsdl-1.1.5.ebuild,v 1.4 2000/11/01 04:44:17 achim Exp $
-
-A=SDL-${PV}.tar.gz
-S=${WORKDIR}/SDL-${PV}
-DESCRIPTION="Simple Direct Media Layer"
-SRC_URI="http://www.libsdl.org/release/"${A}
-HOMEPAGE="http://www.libsdl.org/"
-
-DEPEND=">=sys-apps/bash-2.04
- >=sys-libs/glibc-2.1.3
- >=dev-lang/nasm-0.98
- >=media-libs/alsa-lib-0.5.9
- >=media-libs/audiofile-0.1.9
- >=media-sound/esound-0.2.19
- >=x11-base/xfree-4.0.1"
-
-src_unpack() {
- unpack ${A}
-}
-
-src_compile() {
- cd ${S}
- try ./configure --host=${CHOST} --prefix=/usr
- try make
-}
-
-src_install() {
- cd ${S}
- try make DESTDIR=${D} install
- prepman
- dodoc BUGS COPYING CREDITS README* TODO WhatsNew
- docinto html
- dodoc *.html
- docinto html/docs
- dodoc docs/*.html
-
-}
-
-
-
-
diff --git a/media-libs/libungif/files/digest-libungif-4.1.0_beta1-r1 b/media-libs/libungif/files/digest-libungif-4.1.0_beta1-r1
deleted file mode 100644
index 31863ead2add..000000000000
--- a/media-libs/libungif/files/digest-libungif-4.1.0_beta1-r1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 20d96eb90cf818a1da093614c44ad3e5 libungif-4.1.0b1.tar.gz
diff --git a/media-libs/libungif/libungif-4.1.0_beta1-r1.ebuild b/media-libs/libungif/libungif-4.1.0_beta1-r1.ebuild
deleted file mode 100644
index 8e982e02b8a4..000000000000
--- a/media-libs/libungif/libungif-4.1.0_beta1-r1.ebuild
+++ /dev/null
@@ -1,32 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libungif/libungif-4.1.0_beta1-r1.ebuild,v 1.2 2000/09/15 20:09:03 drobbins Exp $
-
-P=libungif-4.1.0b1
-A=${P}.tar.gz
-S=${WORKDIR}/${P}
-DESCRIPTION="giflib"
-SRC_URI="ftp://prtr-13.ucsc.edu/pub/libungif/"${A}
-HOMEPAGE="http://prtr-13.ucsc.edu/~badger/software/libungif/index.shtml"
-
-src_compile() {
- cd ${S}
- try ./configure --host=${CHOST} --prefix=/usr
- try make
-}
-
-src_install() {
- cd ${S}
- try make prefix=${D}/usr install
- dodoc AUTHORS BUGS COPYING ChangeLog NEWS ONEWS
- dodoc UNCOMPRESSED_GIF README TODO
- dodoc doc/*.txt
- docinto html
- dodoc doc/*.html doc/*.png
-}
-
-
-
-
-
diff --git a/media-libs/mesa-glu/mesa-glu-3.2.1.ebuild b/media-libs/mesa-glu/mesa-glu-3.2.1.ebuild
deleted file mode 100644
index 6c5b237ade30..000000000000
--- a/media-libs/mesa-glu/mesa-glu-3.2.1.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa-glu/mesa-glu-3.2.1.ebuild,v 1.1 2000/12/05 23:27:55 drobbins Exp $
-
-P=MesaLib-${PV}
-A=${P}.tar.gz
-S=${WORKDIR}/Mesa-${PV}
-DESCRIPTION="OpenGL like graphic library for Linux"
-SRC_URI="ftp://gd.tuwien.ac.at/graphics/libs/Mesa/${A}"
-HOMEPAGE="http://mesa3d.sourceforge.net/"
-
-DEPEND=">=sys-libs/glibc-2.1.3
- >=x11-base/xfree-4.0.1"
-
-src_compile() {
-
- cd ${S}
- try ./configure --prefix=/usr/X11R6 --sysconfdir=/etc/mesa --host=${CHOST}
- try make
-
-}
-
-src_install () {
-
- cd ${S}
- try make DESTDIR=${D} install
- rm -f ${D}/usr/X11R6/lib/libGL.*
-
- rm -f ${D}/usr/X11R6/include/GL/gl.h
- rm -f ${D}/usr/X11R6/include/GL/glx.h
- rm -f ${D}/usr/X11R6/include/GL/osmesa.h
- cd ${D}/usr/X11R6/lib
- ln -s libGLU.so.1.1.030201 libMesaGLU.so.3
-
- cd ${S}
- dodoc docs/*
-}
-
diff --git a/media-libs/mesa/files/digest-mesa-glu-3.2.1 b/media-libs/mesa/files/digest-mesa-glu-3.2.1
deleted file mode 100644
index 8600dc9088ee..000000000000
--- a/media-libs/mesa/files/digest-mesa-glu-3.2.1
+++ /dev/null
@@ -1 +0,0 @@
-MD5 5b1c54fb8f0f130ac53cceb5010460f6 MesaLib-3.2.1.tar.gz
diff --git a/media-libs/mesa/files/digest-mesa-glu-3.4 b/media-libs/mesa/files/digest-mesa-glu-3.4
deleted file mode 100644
index 5184b611227e..000000000000
--- a/media-libs/mesa/files/digest-mesa-glu-3.4
+++ /dev/null
@@ -1 +0,0 @@
-MD5 e88f755ed22b0377ee660bd82e2ad8b4 MesaLib-3.4.tar.gz
diff --git a/media-libs/mesa/mesa-glu-3.2.1.ebuild b/media-libs/mesa/mesa-glu-3.2.1.ebuild
deleted file mode 100644
index 8e968b1e8d90..000000000000
--- a/media-libs/mesa/mesa-glu-3.2.1.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/mesa-glu-3.2.1.ebuild,v 1.3 2000/11/01 04:44:18 achim Exp $
-
-P=MesaLib-${PV}
-A=${P}.tar.gz
-S=${WORKDIR}/Mesa-${PV}
-DESCRIPTION="OpenGL like graphic library for Linux"
-SRC_URI="ftp://gd.tuwien.ac.at/graphics/libs/Mesa/${A}"
-HOMEPAGE="http://mesa3d.sourceforge.net/"
-
-DEPEND=">=sys-libs/glibc-2.1.3
- >=x11-base/xfree-4.0.1"
-
-src_compile() {
-
- cd ${S}
- try ./configure --prefix=/usr/X11R6 --sysconfdir=/etc/mesa --host=${CHOST}
- try make
-
-}
-
-src_install () {
-
- cd ${S}
- try make DESTDIR=${D} install
- rm -f ${D}/usr/X11R6/lib/libGL.*
-
- rm -f ${D}/usr/X11R6/include/GL/gl.h
- rm -f ${D}/usr/X11R6/include/GL/glx.h
- rm -f ${D}/usr/X11R6/include/GL/osmesa.h
- cd ${D}/usr/X11R6/lib
- ln -s libGLU.so.1.1.030201 libMesaGLU.so.3
-
- cd ${S}
- dodoc docs/*
-}
-
diff --git a/media-libs/mesa/mesa-glu-3.4.ebuild b/media-libs/mesa/mesa-glu-3.4.ebuild
deleted file mode 100644
index 4b43870fba90..000000000000
--- a/media-libs/mesa/mesa-glu-3.4.ebuild
+++ /dev/null
@@ -1,40 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mesa/mesa-glu-3.4.ebuild,v 1.2 2000/11/27 22:48:59 achim Exp $
-
-P=MesaLib-${PV}
-A=${P}.tar.gz
-S=${WORKDIR}/Mesa-${PV}
-DESCRIPTION="OpenGL like graphic library for Linux"
-SRC_URI="ftp://gd.tuwien.ac.at/graphics/libs/Mesa/${A}"
-HOMEPAGE="http://mesa3d.sourceforge.net/"
-
-DEPEND=">=sys-libs/glibc-2.1.3
- >=x11-base/xfree-4.0.1"
-
-src_compile() {
-
- cd ${S}
- try ./configure --prefix=/usr/X11R6 --sysconfdir=/etc/mesa --host=${CHOST}
- try make
-
-}
-
-src_install () {
-
- cd ${S}
- try make DESTDIR=${D} install
-# rm -f ${D}/usr/X11R6/lib/libGL.*
-
-# rm -f ${D}/usr/X11R6/include/GL/gl.h
-# rm -f ${D}/usr/X11R6/include/GL/glx.h
-# rm -f ${D}/usr/X11R6/include/GL/osmesa.h
- cd ${D}/usr/X11R6/lib
- ln -s libGLU.so.1.1.030400 libMesaGLU.so.3
- ln -s libGL.so.2.1.030400 libMesaGL.so.3
-
- cd ${S}
- dodoc docs/*
-}
-
diff --git a/media-libs/mpeg2vidcodec/files/digest-mpeg2vidcodec-12 b/media-libs/mpeg2vidcodec/files/digest-mpeg2vidcodec-12
deleted file mode 100644
index 8a1a59cfd148..000000000000
--- a/media-libs/mpeg2vidcodec/files/digest-mpeg2vidcodec-12
+++ /dev/null
@@ -1 +0,0 @@
-MD5 4a66565979be0818bd8a41d948943451 mpeg2vidcodec_v12.tar.gz
diff --git a/media-libs/mpeg2vidcodec/mpeg2vidcodec-12.ebuild b/media-libs/mpeg2vidcodec/mpeg2vidcodec-12.ebuild
deleted file mode 100644
index c24387169e8b..000000000000
--- a/media-libs/mpeg2vidcodec/mpeg2vidcodec-12.ebuild
+++ /dev/null
@@ -1,39 +0,0 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
-# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/media-libs/mpeg2vidcodec/mpeg2vidcodec-12.ebuild,v 1.2 2000/11/01 04:44:18 achim Exp $
-
-P=mpeg2vidcodec_v12
-A=${P}.tar.gz
-S=${WORKDIR}/mpeg2
-DESCRIPTION="MPEG Library"
-SRC_URI="ftp://ftp.mpeg.org/pub/mpeg/mssg/${A}"
-HOMEPAGE="http://www.mpeg.org"
-
-DEPEND=">=sys-libs/glibc-2.1.3"
-
-src_unpack () {
-
- unpack ${A}
- cd ${S}
- cp Makefile Makefile.orig
- sed -e "s:-O2:${CFLAGS}:" Makefile.orig > Makefile
-
-}
-src_compile() {
-
- cd ${S}
- try make
-
-}
-
-src_install () {
-
- cd ${S}
- into /usr/X11R6
- dobin src/mpeg2dec/mpeg2decode
- dobin src/mpeg2enc/mpeg2encode
- dodoc README doc/*
-
-}
-