summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-libs/libpng')
-rw-r--r--media-libs/libpng/ChangeLog7
-rw-r--r--media-libs/libpng/Manifest24
-rw-r--r--media-libs/libpng/files/libpng-1.2.8-build.patch79
3 files changed, 92 insertions, 18 deletions
diff --git a/media-libs/libpng/ChangeLog b/media-libs/libpng/ChangeLog
index 391828d7b583..f87dea85da99 100644
--- a/media-libs/libpng/ChangeLog
+++ b/media-libs/libpng/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for media-libs/libpng
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-libs/libpng/ChangeLog,v 1.69 2005/10/11 00:43:05 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-libs/libpng/ChangeLog,v 1.70 2005/10/30 09:14:06 grobian Exp $
+
+ 30 Oct 2005; Fabian Groffen <grobian@gentoo.org>
+ files/libpng-1.2.8-build.patch:
+ Added patching of makefile.darwin to libpng-1.2.8-build.patch. Solves bug
+ #109957
*libpng-1.2.8-r1 (11 Oct 2005)
diff --git a/media-libs/libpng/Manifest b/media-libs/libpng/Manifest
index adbf18048c2c..a6ea79a2a76f 100644
--- a/media-libs/libpng/Manifest
+++ b/media-libs/libpng/Manifest
@@ -1,20 +1,10 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
-MD5 3dc3e31fcdf329242bc180444a57f30b ChangeLog 11097
-MD5 3338fff0166374e14ae138e6a1f4cd21 files/1.2.7-gentoo.diff 464
-MD5 cfc3cad1942561090fafce6a25a23bf0 files/digest-libpng-1.2.8 127
-MD5 cfc3cad1942561090fafce6a25a23bf0 files/digest-libpng-1.2.8-r1 127
-MD5 f13493ee891ede4548a44ad32d56552f files/libpng-1.2.8-build.patch 1857
-MD5 029ec280f20678b76004c1a0a0270111 files/libpng-1.2.8-strnlen.patch 580
-MD5 7443cfcd027ad293e56ec7bed76ee21c files/macos.patch 589
MD5 0897ccaeb4909330e541daf8e1da5938 libpng-1.2.8-r1.ebuild 1691
MD5 67b7ae796734a04480c98efbb6ee7c06 libpng-1.2.8.ebuild 1813
+MD5 3dc3e31fcdf329242bc180444a57f30b ChangeLog 11097
MD5 9a09f8d531c582e78977dbfd96edc1f2 metadata.xml 164
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.2 (GNU/Linux)
-
-iD8DBQFDSwsMgIKl8Uu19MoRAiTMAJ4zHMjNLzYyQSJhZ0Ae8NMwb2Q84gCfWWaG
-F39Qy55pKonW2ZRrG7fsJlU=
-=feRS
------END PGP SIGNATURE-----
+MD5 cfc3cad1942561090fafce6a25a23bf0 files/digest-libpng-1.2.8 127
+MD5 3338fff0166374e14ae138e6a1f4cd21 files/1.2.7-gentoo.diff 464
+MD5 7443cfcd027ad293e56ec7bed76ee21c files/macos.patch 589
+MD5 029ec280f20678b76004c1a0a0270111 files/libpng-1.2.8-strnlen.patch 580
+MD5 cfc3cad1942561090fafce6a25a23bf0 files/digest-libpng-1.2.8-r1 127
+MD5 2a7e38438ec298bb296fdb07c8666559 files/libpng-1.2.8-build.patch 3789
diff --git a/media-libs/libpng/files/libpng-1.2.8-build.patch b/media-libs/libpng/files/libpng-1.2.8-build.patch
index 77d186d2057d..f1161d506b73 100644
--- a/media-libs/libpng/files/libpng-1.2.8-build.patch
+++ b/media-libs/libpng/files/libpng-1.2.8-build.patch
@@ -72,3 +72,82 @@ Clean up build system to make cross-compiling easy
pngtest-static: pngtest.o libpng.a
$(CC) -o pngtest-static $(CFLAGS) pngtest.o $(LDFLAGS_A)
+--- scripts/makefile.darwin 2005-10-30 09:55:21.000000000 +0100
++++ scripts/makefile.darwin 2005-10-30 10:08:38.000000000 +0100
+@@ -7,20 +7,30 @@
+ # For conditions of distribution and use, see copyright notice in png.h
+
+ # where "make install" puts libpng.a, libpng12.dylib, png.h and pngconf.h
+-prefix=/usr/local
++prefix=/usr
+
+ # Where the zlib library and include files are located
+ #ZLIBLIB=/usr/local/lib
+ #ZLIBINC=/usr/local/include
+-ZLIBLIB=../zlib
+-ZLIBINC=../zlib
++ZLIBLIB=./zlib
++ZLIBINC=./zlib
+
+-CC=cc
+-CFLAGS=-I$(ZLIBINC) -Wall -O3 -funroll-loops
+-LDFLAGS=-L. -L$(ZLIBLIB) -lpng12 -lz
++CC?=gcc
++
++CFLAGS += -Wall $(ALIGN)
++ifneq ($(ZLIBINC),)
++CFLAGS += -I$(ZLIBINC)
++endif
++
++ifneq ($(ZLIBLIB),)
++LDFLAGS += -L$(ZLIBLIB)
++endif
++LDFLAGS += -lz
++LDFLAGS_DYLIB = $(LDFLAGS) -L. -lpng12
+
+ #RANLIB=echo
+-RANLIB=ranlib
++AR?=ar
++RANLIB?=ranlib
+
+ PNGMAJ = 0
+ PNGMIN = 1.2.8
+@@ -29,7 +39,7 @@
+
+ INCPATH=$(prefix)/include
+ LIBPATH=$(prefix)/lib
+-MANPATH=$(prefix)/man
++MANPATH=$(prefix)/share/man
+ BINPATH=$(prefix)/bin
+
+ # override DESTDIR= on the make install command line to easily support
+@@ -61,7 +71,7 @@
+ all: libpng.a $(LIBNAME).dylib pngtest libpng.pc libpng-config
+
+ libpng.a: $(OBJS)
+- ar rc $@ $(OBJS)
++ $(AR) rc $@ $(OBJS)
+ $(RANLIB) $@
+
+ libpng.pc:
+@@ -88,17 +98,17 @@
+ -install_name $(LIBPATH)/$(LIBNAME).$(PNGMAJ).dylib \
+ -current_version $(PNGVER) -compatibility_version $(PNGVER) \
+ -o $(LIBNAME).$(PNGVER).dylib \
+- $(OBJSDLL) -L$(ZLIBLIB) -lz
++ $(OBJSDLL) $(LDFLAGS)
+
+ libpng.3.$(PNGMIN).dylib: $(OBJSDLL)
+ $(CC) -dynamiclib \
+ -install_name $(LIBPATH)/libpng.3.dylib \
+ -current_version 3 -compatibility_version 3 \
+ -o libpng.3.$(PNGMIN).dylib \
+- $(OBJSDLL) -L$(ZLIBLIB) -lz
++ $(OBJSDLL) $(LDFLAGS)
+
+ pngtest: pngtest.o $(LIBNAME).dylib
+- $(CC) -o pngtest $(CFLAGS) pngtest.o $(LDFLAGS)
++ $(CC) -o pngtest $(CFLAGS) pngtest.o $(LDFLAGS_DYLIB)
+
+ test: pngtest
+ ./pngtest