summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'media-gfx/zphoto')
-rw-r--r--media-gfx/zphoto/ChangeLog5
-rw-r--r--media-gfx/zphoto/zphoto-1.2-r1.ebuild17
2 files changed, 16 insertions, 6 deletions
diff --git a/media-gfx/zphoto/ChangeLog b/media-gfx/zphoto/ChangeLog
index 6808fcc4a9e3..292e8ab50d82 100644
--- a/media-gfx/zphoto/ChangeLog
+++ b/media-gfx/zphoto/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for media-gfx/zphoto
# Copyright 2000-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/zphoto/ChangeLog,v 1.12 2005/05/29 18:54:22 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/zphoto/ChangeLog,v 1.13 2005/06/04 10:58:30 usata Exp $
+
+ 04 Jun 2005; Mamoru KOMACHI <usata@gentoo.org> zphoto-1.2-r1.ebuild:
+ Make wxzphoto compile with wxGTK-2.6; bug #94601.
29 May 2005; Mamoru KOMACHI <usata@gentoo.org> zphoto-1.2-r1.ebuild:
Stable on x86.
diff --git a/media-gfx/zphoto/zphoto-1.2-r1.ebuild b/media-gfx/zphoto/zphoto-1.2-r1.ebuild
index badd637fe1b6..993333b073e3 100644
--- a/media-gfx/zphoto/zphoto-1.2-r1.ebuild
+++ b/media-gfx/zphoto/zphoto-1.2-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2005 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/media-gfx/zphoto/zphoto-1.2-r1.ebuild,v 1.2 2005/05/29 18:54:22 usata Exp $
+# $Header: /var/cvsroot/gentoo-x86/media-gfx/zphoto/zphoto-1.2-r1.ebuild,v 1.3 2005/06/04 10:58:30 usata Exp $
IUSE="wxwindows gtk2"
@@ -24,11 +24,18 @@ src_compile() {
local myconf
if use wxwindows ; then
- if use gtk2 ; then
- myconf="--with-wx-config=/usr/bin/wxgtk2-2.4-config"
- else
- myconf="--with-wx-config=/usr/bin/wxgtk-2.4-config"
+ if use gtk2 && has_version '>=x11-libs/wxGTK-2.6' ; then
+ wx_config="/usr/bin/wx-config-2.6"
+ sed -i -e 's@\($WXCONFIG --cflags\)@\1 --unicode=no@' \
+ -e 's@\($WXCONFIG --libs\)@\1 --unicode=no@' \
+ configure || die
+ sed -i -e 's@FALSE@false@g' wxzphoto.cpp || die
+ elif use gtk2 ; then
+ wx_config="/usr/bin/wxgtk2-2.4-config"
+ else # gtk1
+ wx_config="/usr/bin/wxgtk-2.4-config"
fi
+ myconf="--with-wx-config=$wx_config"
else
myconf="--disable-wx"
fi