summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'mail-client/evolution/evolution-2.32.3.ebuild')
-rw-r--r--mail-client/evolution/evolution-2.32.3.ebuild23
1 files changed, 4 insertions, 19 deletions
diff --git a/mail-client/evolution/evolution-2.32.3.ebuild b/mail-client/evolution/evolution-2.32.3.ebuild
index b4009e092e30..b23837980db4 100644
--- a/mail-client/evolution/evolution-2.32.3.ebuild
+++ b/mail-client/evolution/evolution-2.32.3.ebuild
@@ -1,9 +1,10 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/mail-client/evolution/evolution-2.32.3.ebuild,v 1.1 2011/06/19 21:35:48 pacho Exp $
+# $Header: /var/cvsroot/gentoo-x86/mail-client/evolution/evolution-2.32.3.ebuild,v 1.2 2011/10/08 21:25:45 pacho Exp $
EAPI="3"
GCONF_DEBUG="no"
+GNOME2_LA_PUNT="yes"
PYTHON_DEPEND="python? 2:2.4"
inherit autotools flag-o-matic gnome2 python versionator
@@ -18,7 +19,7 @@ SRC_URI="${SRC_URI} http://dev.gentoo.org/~pacho/gnome/${P}-patches.tar.xz"
LICENSE="GPL-2 LGPL-2 OPENLDAP"
SLOT="2.0"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
-IUSE="clutter connman crypt doc gstreamer kerberos ldap networkmanager python ssl"
+IUSE="clutter crypt doc gstreamer kerberos ldap networkmanager python ssl"
# We need a graphical pinentry frontend to be able to ask for the GPG
# password from inside evolution, bug 160302
@@ -47,7 +48,6 @@ RDEPEND=">=dev-libs/glib-2.25.12:2
>=dev-libs/libgdata-0.4
clutter? ( media-libs/clutter:1.0[gtk] )
- connman? ( net-misc/connman )
crypt? ( || (
( >=app-crypt/gnupg-2.0.1-r2
${PINENTRY_DEPEND} )
@@ -91,7 +91,7 @@ pkg_setup() {
$(use_enable ssl nss)
$(use_enable ssl smime)
$(use_enable networkmanager nm)
- $(use_enable connman)
+ --disable-connman
$(use_enable gstreamer audio-inline)
--disable-profiling
--disable-pst-import
@@ -120,12 +120,6 @@ pkg_setup() {
--without-nss-includes"
fi
- # NM and connman support cannot coexist
- if use networkmanager && use connman ; then
- ewarn "It is not possible to enable both ConnMan and NetworkManager, disabling connman..."
- G2CONF="${G2CONF} --disable-connman"
- fi
-
python_set_active_version 2
}
@@ -161,15 +155,6 @@ src_prepare() {
eautoreconf
}
-src_install() {
- gnome2_src_install
-
- find "${ED}"/usr/$(get_libdir)/evolution/${MY_MAJORV}/plugins \
- -name "*.la" -delete || die "la files removal failed 1"
- find "${ED}"/usr/$(get_libdir)/evolution/${MY_MAJORV}/modules \
- -name "*.la" -delete || die "la files removal failed 2"
-}
-
pkg_postinst() {
gnome2_pkg_postinst