summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'lxde-base/lxpolkit/lxpolkit-0_p20110122.ebuild')
-rw-r--r--lxde-base/lxpolkit/lxpolkit-0_p20110122.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/lxde-base/lxpolkit/lxpolkit-0_p20110122.ebuild b/lxde-base/lxpolkit/lxpolkit-0_p20110122.ebuild
new file mode 100644
index 000000000000..d3479bfa858e
--- /dev/null
+++ b/lxde-base/lxpolkit/lxpolkit-0_p20110122.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/lxde-base/lxpolkit/lxpolkit-0_p20110122.ebuild,v 1.1 2011/01/22 21:33:22 hwoarang Exp $
+
+EAPI=3
+inherit autotools
+
+DESCRIPTION="A simple PolicyKit auhentication agent"
+HOMEPAGE="http://blog.lxde.org/?p=674"
+SRC_URI="http://dev.gentoo.org/~hwoarang/distfiles/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-libs/glib-2.18:2
+ >=lxde-base/menu-cache-0.3.2
+ >=sys-auth/polkit-0.99
+ >=x11-libs/gtk+-2.12:2
+ !gnome-extra/polkit-gnome"
+DEPEND="${RDEPEND}
+ app-arch/xz-utils
+ >=dev-util/intltool-0.40.0
+ dev-util/pkgconfig
+ sys-devel/gettext"
+
+src_prepare() {
+ # NotShowIn=KDE; because they have polkit-kde, but this
+ # is exchangeable with polkit-gnome. The blocker is valid,
+ # and it's other packages that need || ( ) deps.
+ sed -i -e '/ShowIn/d' data/lxpolkit.desktop.in.in || die
+ echo 'NotShowIn=KDE;' >> data/lxpolkit.desktop.in.in
+
+ intltoolize --force --copy --automake
+ eautoreconf
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc AUTHORS
+}