summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/noatun/noatun-3.4.0.ebuild')
-rw-r--r--kde-base/noatun/noatun-3.4.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/kde-base/noatun/noatun-3.4.0.ebuild b/kde-base/noatun/noatun-3.4.0.ebuild
new file mode 100644
index 000000000000..71b1699a9934
--- /dev/null
+++ b/kde-base/noatun/noatun-3.4.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/noatun/noatun-3.4.0.ebuild,v 1.1 2005/03/13 21:19:12 danarmak Exp $
+
+KMNAME=kdemultimedia
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta eutils
+
+DESCRIPTION="KDE media player"
+KEYWORDS="~x86"
+IUSE="xine audiofile"
+RDEPEND="${DEPEND}
+$(deprange $PV $MAXKDEVER kde-base/kdemultimedia-arts)
+$(deprange $PV $MAXKDEVER kde-base/artsplugin-mpeglib)
+$(deprange $PV $MAXKDEVER kde-base/artsplugin-mpg123)
+ xine? ( $(deprange $PV $MAXKDEVER kde-base/artsplugin-xine) )
+ audiofile? ( $(deprange $PV $MAXKDEVER kde-base/artsplugin-audiofile) )"
+KMCOPYLIB="
+ libartsgui_kde arts/gui/kde/
+ libartsgui arts/gui/common/
+ libartsmodules arts/modules/"
+KMEXTRACTONLY="arts/"
+
+pkg_setup() {
+ if ! useq arts; then
+ eerror "${PN} needs the USE=\"arts\" enabled and also the kdelibs compiled with the USE=\"arts\" enabled"
+ die
+ fi
+} \ No newline at end of file