summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kwin/kwin-3.5.6-r1.ebuild')
-rw-r--r--kde-base/kwin/kwin-3.5.6-r1.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/kde-base/kwin/kwin-3.5.6-r1.ebuild b/kde-base/kwin/kwin-3.5.6-r1.ebuild
new file mode 100644
index 000000000000..9a7f40f4bd0a
--- /dev/null
+++ b/kde-base/kwin/kwin-3.5.6-r1.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kwin/kwin-3.5.6-r1.ebuild,v 1.1 2007/04/30 20:07:34 carlo Exp $
+
+KMNAME=kdebase
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta eutils
+
+DESCRIPTION="KDE window manager"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="kdehiddenvisibility xcomposite"
+RDEPEND="xcomposite? ( x11-libs/libXcomposite x11-libs/libXdamage )"
+DEPEND="${RDEPEND}"
+
+SRC_URI="${SRC_URI}
+ mirror://gentoo/${PN}-3.5.5-seli-xinerama.patch.bz2
+ mirror://gentoo/kdebase-3.5-patchset-04.tar.bz2"
+
+PATCHES="${DISTDIR}/${PN}-3.5.5-seli-xinerama.patch.bz2"
+
+src_compile() {
+ myconf="$myconf $(use_with xcomposite composite)"
+ kde-meta_src_compile
+}