summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/kwin/kwin-3.5.0.ebuild')
-rw-r--r--kde-base/kwin/kwin-3.5.0.ebuild23
1 files changed, 20 insertions, 3 deletions
diff --git a/kde-base/kwin/kwin-3.5.0.ebuild b/kde-base/kwin/kwin-3.5.0.ebuild
index 3f32ec4b043a..74d147f63377 100644
--- a/kde-base/kwin/kwin-3.5.0.ebuild
+++ b/kde-base/kwin/kwin-3.5.0.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2005 Gentoo Foundation
+# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/kde-base/kwin/kwin-3.5.0.ebuild,v 1.4 2005/12/17 10:18:32 corsair Exp $
+# $Header: /var/cvsroot/gentoo-x86/kde-base/kwin/kwin-3.5.0.ebuild,v 1.5 2006/01/11 19:24:57 flameeyes Exp $
KMNAME=kdebase
MAXKDEVER=$PV
@@ -9,5 +9,22 @@ inherit kde-meta eutils
DESCRIPTION="KDE window manager"
KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
-IUSE=""
+IUSE="xcomposite"
+RDEPEND="xcomposite? ( || ( (
+ x11-libs/libXcomposite
+ x11-libs/libXdamage
+ ) <=x11-base/xorg-x11-6.9 )
+ )"
+DEPEND="${RDEPEND}
+ xcomposite? ( || ( (
+ x11-proto/compositeproto
+ x11-proto/damageproto
+ ) <=x11-base/xorg-x11-6.9 )
+ )"
+PATCHES="${FILESDIR}/${P}-composite.patch"
+
+src_compile() {
+ myconf="$myconf $(use_with xcomposite composite)"
+ kde-meta_src_compile
+}