summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'kde-base/dcoppython/dcoppython-3.4.2.ebuild')
-rw-r--r--kde-base/dcoppython/dcoppython-3.4.2.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/kde-base/dcoppython/dcoppython-3.4.2.ebuild b/kde-base/dcoppython/dcoppython-3.4.2.ebuild
new file mode 100644
index 000000000000..9dd86d3adf98
--- /dev/null
+++ b/kde-base/dcoppython/dcoppython-3.4.2.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/kde-base/dcoppython/dcoppython-3.4.2.ebuild,v 1.1 2005/07/28 21:16:10 danarmak Exp $
+
+KMNAME=kdebindings
+KM_MAKEFILESREV=1
+MAXKDEVER=$PV
+KM_DEPRANGE="$PV $MAXKDEVER"
+inherit kde-meta
+
+DESCRIPTION="KDE: Python bindings for DCOP"
+KEYWORDS=" ~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+DEPEND="virtual/python"
+PATCHES="$FILESDIR/no-gtk-glib-check.diff"
+
+# Because this installs into /usr/lib/python2.3/..., it doesn't have SLOT=X.Y like the rest of KDE,
+# and it installs into /usr entirely
+SLOT="0"
+src_compile() {
+ kde_src_compile myconf
+ myconf="$myconf --prefix=/usr"
+ kde_src_compile configure make
+}
+