summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnustep-base/gnustep-back-xlib/gnustep-back-xlib-0.9.5_pre20040928.ebuild')
-rw-r--r--gnustep-base/gnustep-back-xlib/gnustep-back-xlib-0.9.5_pre20040928.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/gnustep-base/gnustep-back-xlib/gnustep-back-xlib-0.9.5_pre20040928.ebuild b/gnustep-base/gnustep-back-xlib/gnustep-back-xlib-0.9.5_pre20040928.ebuild
new file mode 100644
index 000000000000..a5555ab4a301
--- /dev/null
+++ b/gnustep-base/gnustep-back-xlib/gnustep-back-xlib-0.9.5_pre20040928.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2004 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnustep-base/gnustep-back-xlib/gnustep-back-xlib-0.9.5_pre20040928.ebuild,v 1.1 2004/09/28 17:50:52 fafhrd Exp $
+
+ECVS_CVS_COMMAND="cvs -q"
+ECVS_SERVER="savannah.gnu.org:/cvsroot/gnustep"
+ECVS_USER="anoncvs"
+ECVS_AUTH="ext"
+ECVS_MODULE="gnustep/core/back"
+ECVS_CO_OPTS="-D ${PV/*_pre}"
+ECVS_UP_OPTS="-D ${PV/*_pre}"
+ECVS_TOP_DIR="${DISTDIR}/cvs-src/savannah.gnu.org-gnustep"
+inherit gnustep cvs
+
+S=${WORKDIR}/${ECVS_MODULE}
+
+DESCRIPTION="Default X11 back-end component for the GNUstep GUI Library."
+HOMEPAGE="http://www.gnustep.org"
+
+KEYWORDS="~x86"
+SLOT="0"
+LICENSE="LGPL-2.1"
+
+PROVIDE="virtual/gnustep-back"
+
+IUSE="${IUSE} opengl xim doc"
+DEPEND="${GNUSTEP_GUI_DEPEND}
+ =gnustep-base/gnustep-gui-${PV}
+ opengl? ( virtual/opengl virtual/glu )
+ virtual/xft
+ =media-libs/freetype-2.1*"
+RDEPEND="${DEPEND}
+ ${DOC_RDEPEND}"
+
+src_compile() {
+ egnustep_env
+
+ use opengl && myconf="--enable-glx"
+ myconf="$myconf `use_enable xim`"
+ myconf="$myconf --enable-server=x11"
+ myconf="$myconf --enable-graphics=xlib --with-name=xlib"
+ econf $myconf || die "configure failed"
+
+ egnustep_make
+}
+