summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'gnome-extra/libgtkhtml/libgtkhtml-3.0.10-r1.ebuild')
-rw-r--r--gnome-extra/libgtkhtml/libgtkhtml-3.0.10-r1.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/gnome-extra/libgtkhtml/libgtkhtml-3.0.10-r1.ebuild b/gnome-extra/libgtkhtml/libgtkhtml-3.0.10-r1.ebuild
new file mode 100644
index 000000000000..503a7e4366c9
--- /dev/null
+++ b/gnome-extra/libgtkhtml/libgtkhtml-3.0.10-r1.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2004 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/gnome-extra/libgtkhtml/libgtkhtml-3.0.10-r1.ebuild,v 1.1 2004/06/19 16:10:12 usata Exp $
+
+inherit gnome2 eutils
+
+MY_P=${P/lib/}
+MY_PN=${PN/lib/}
+DESCRIPTION="Lightweight HTML Rendering/Printing/Editing Engine"
+HOMEPAGE="http://www.gnome.org/"
+
+# stolen from gnome.org eclass because it support this one-off name-mangling
+
+[ -z "${GNOME_TARBALL_SUFFIX}" ] && export GNOME_TARBALL_SUFFIX="bz2"
+PVP=($(echo " $PV " | sed 's:[-\._]: :g'))
+SRC_URI="mirror://gnome/sources/${MY_PN}/${PVP[0]}.${PVP[1]}/${MY_P}.tar.${GNOME_TARBALL_SUFFIX}"
+LICENSE="GPL-2"
+SLOT="3"
+KEYWORDS="~x86 ~ppc sparc ~hppa ~alpha ~ia64 ~amd64"
+IUSE=""
+
+S=${WORKDIR}/${MY_P}
+
+RDEPEND=">=gnome-extra/gal-1.99.11
+ >=net-libs/libsoup-1.99.28
+ >=gnome-base/libgnomeui-2.2
+ >=gnome-base/libgnomeprint-2.2
+ >=gnome-base/libgnomeprintui-2.2.1
+ >=gnome-base/libbonoboui-2.0
+ >=gnome-base/libbonobo-2.0
+ >=gnome-base/ORBit2-2.5.6
+ >=gnome-base/gnome-vfs-2.1
+ >=gnome-base/gail-1.1
+ >=dev-libs/libxml2-2.5"
+
+DEPEND="${RDEPEND}
+ >=dev-util/pkgconfig-0.12.0"
+
+USE_DESTDIR="1"
+SCROLLKEEPER_UPDATE="0"
+ELTCONF="--reverse-deps"
+
+src_unpack() {
+ unpack ${A}
+
+ cd ${S}/src
+ # bug 54244, patch for cjk input methods
+ epatch ${FILESDIR}/${PN}-fix_preedit.patch
+}
+
+src_compile() {
+ gnome2_src_configure
+
+ EPATCH_OPTS="${S}/libtool"
+ epatch ${FILESDIR}/${PN}-3.0.7-libtool.patch
+
+ emake || die "make failed"
+}