summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-strategy')
-rw-r--r--games-strategy/glob2/ChangeLog8
-rw-r--r--games-strategy/glob2/glob2-0.9.4.1.ebuild51
2 files changed, 58 insertions, 1 deletions
diff --git a/games-strategy/glob2/ChangeLog b/games-strategy/glob2/ChangeLog
index 9c7788c297b0..f5a3ece6e933 100644
--- a/games-strategy/glob2/ChangeLog
+++ b/games-strategy/glob2/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for games-strategy/glob2
# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-strategy/glob2/ChangeLog,v 1.44 2009/02/24 23:48:06 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/glob2/ChangeLog,v 1.45 2009/03/26 20:38:32 mr_bones_ Exp $
+
+*glob2-0.9.4.1 (26 Mar 2009)
+
+ 26 Mar 2009; Michael Sterrett <mr_bones_@gentoo.org>
+ +glob2-0.9.4.1.ebuild:
+ version bump
*glob2-0.9.4 (24 Feb 2009)
diff --git a/games-strategy/glob2/glob2-0.9.4.1.ebuild b/games-strategy/glob2/glob2-0.9.4.1.ebuild
new file mode 100644
index 000000000000..a46ae65d8f1c
--- /dev/null
+++ b/games-strategy/glob2/glob2-0.9.4.1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-strategy/glob2/glob2-0.9.4.1.ebuild,v 1.1 2009/03/26 20:38:32 mr_bones_ Exp $
+
+EAPI=2
+inherit eutils games
+
+DESCRIPTION="Real Time Strategy (RTS) game involving a brave army of globs"
+HOMEPAGE="http://globulation2.org/"
+SRC_URI="http://dl.sv.nongnu.org/releases/glob2/0.9.4/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~hppa ~ppc ~x86"
+IUSE=""
+
+RDEPEND="virtual/opengl
+ virtual/glu
+ >=dev-libs/boost-1.34
+ media-libs/libsdl[opengl]
+ media-libs/sdl-net
+ media-libs/sdl-ttf
+ media-libs/sdl-image
+ media-libs/libvorbis
+ dev-libs/fribidi
+ media-libs/speex"
+DEPEND="${RDEPEND}
+ >=dev-util/scons-1"
+
+src_compile() {
+ local sconsopts=$(echo "${MAKEOPTS}" | sed -e "s/.*\(-j[0-9]\+\).*/\1/")
+
+ scons \
+ ${sconsopts} \
+ CXXFLAGS="${CXXFLAGS}" \
+ LINKFLAGS="${LDFLAGS}" \
+ INSTALLDIR="${GAMES_DATADIR}"/${PN} \
+ DATADIR="${GAMES_DATADIR}"/${PN} \
+ || die "scons failed again"
+}
+
+src_install() {
+ dogamesbin src/${PN} || die "dogamesbin failed"
+ insinto "${GAMES_DATADIR}"/${PN}
+ doins -r campaigns data maps scripts || die "doins failed"
+ find "${D}/${GAMES_DATADIR}"/${PN} -name SConscript -exec rm -f {} +
+ newicon data/icons/glob2-icon-48x48.png ${PN}.png
+ make_desktop_entry glob2 "Globulation 2"
+ dodoc README*
+ prepgamesdirs
+}