summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-puzzle')
-rw-r--r--games-puzzle/enigma/ChangeLog8
-rw-r--r--games-puzzle/enigma/enigma-1.01.ebuild8
-rw-r--r--games-puzzle/enigma/files/enigma-1.01-gcc43.patch40
3 files changed, 51 insertions, 5 deletions
diff --git a/games-puzzle/enigma/ChangeLog b/games-puzzle/enigma/ChangeLog
index 147437a46982..1d735b623bf1 100644
--- a/games-puzzle/enigma/ChangeLog
+++ b/games-puzzle/enigma/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for games-puzzle/enigma
-# Copyright 2002-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/enigma/ChangeLog,v 1.35 2007/11/04 23:11:22 tupone Exp $
+# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/enigma/ChangeLog,v 1.36 2008/04/30 15:40:10 nyhm Exp $
+
+ 30 Apr 2008; Tristan Heaven <nyhm@gentoo.org>
+ +files/enigma-1.01-gcc43.patch, enigma-1.01.ebuild:
+ Patch to fix building with gcc-4.3 from Martin Väth, bug #218941
*enigma-1.01 (04 Nov 2007)
diff --git a/games-puzzle/enigma/enigma-1.01.ebuild b/games-puzzle/enigma/enigma-1.01.ebuild
index fe2e1769c669..11a4bb2e5b61 100644
--- a/games-puzzle/enigma/enigma-1.01.ebuild
+++ b/games-puzzle/enigma/enigma-1.01.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-puzzle/enigma/enigma-1.01.ebuild,v 1.1 2007/11/04 23:11:22 tupone Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-puzzle/enigma/enigma-1.01.ebuild,v 1.2 2008/04/30 15:40:10 nyhm Exp $
inherit autotools eutils games
@@ -27,7 +27,9 @@ src_unpack() {
unpack ${A}
cd "${S}"
cp /usr/share/gettext/config.rpath .
- epatch "${FILESDIR}"/${P}-autotools.patch
+ epatch \
+ "${FILESDIR}"/${P}-autotools.patch \
+ "${FILESDIR}"/${P}-gcc43.patch
eautoreconf
}
diff --git a/games-puzzle/enigma/files/enigma-1.01-gcc43.patch b/games-puzzle/enigma/files/enigma-1.01-gcc43.patch
new file mode 100644
index 000000000000..32fba0caca98
--- /dev/null
+++ b/games-puzzle/enigma/files/enigma-1.01-gcc43.patch
@@ -0,0 +1,40 @@
+--- lib-src/enigma-core/ecl_util.hh
++++ lib-src/enigma-core/ecl_util.hh
+@@ -20,6 +20,7 @@
+ #define ECL_UTIL_HH_INCLUDED
+
+ #include <string>
++#include <algorithm>
+
+ /* hide GNU extensions for non-gnu compilers: */
+ #ifndef __GNU__
+--- src/Utf8ToXML.cc
++++ src/Utf8ToXML.cc
+@@ -21,6 +21,7 @@
+ #include "main.hh"
+ #include <xercesc/util/XMLString.hpp>
+ #include <xercesc/util/TransService.hpp>
++#include <cstring>
+
+ XERCES_CPP_NAMESPACE_USE
+
+--- src/file.hh
++++ src/file.hh
+@@ -22,6 +22,7 @@
+ #include <iosfwd>
+ #include <vector>
+ #include <list>
++#include <memory>
+ #include "ecl_error.hh"
+
+ namespace enigma
+--- src/gui/widgets.cc
++++ src/gui/widgets.cc
+@@ -28,6 +28,7 @@
+ #include <cassert>
+ #include <algorithm>
+ #include <iostream>
++#include <climits>
+
+ using namespace enigma::gui;
+ using namespace ecl;