summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/generator/files/generator-0.35-configure.patch')
-rw-r--r--games-emulation/generator/files/generator-0.35-configure.patch61
1 files changed, 0 insertions, 61 deletions
diff --git a/games-emulation/generator/files/generator-0.35-configure.patch b/games-emulation/generator/files/generator-0.35-configure.patch
deleted file mode 100644
index cc4046c7e62b..000000000000
--- a/games-emulation/generator/files/generator-0.35-configure.patch
+++ /dev/null
@@ -1,61 +0,0 @@
---- configure.ac.orig 2007-04-11 16:28:09.000000000 -0400
-+++ configure.ac 2007-04-11 16:29:07.000000000 -0400
-@@ -202,50 +202,6 @@
- CFLAGS="$CFLAGS -Wstrict-prototypes -Wunused"
- fi
- fi
-- if [[ "x$DEBUG" != "xno" ]]; then
-- AC_MSG_RESULT(Turning on debug flags)
-- CFLAGS="$CFLAGS -g -O"
-- optimum=no
-- else
-- if [[ "x$GCCVER" != "xno" ]]; then
-- AC_MSG_RESULT(Turning on gcc optimisations)
-- CFLAGS="$CFLAGS -O3 -fomit-frame-pointer"
-- if [[ "x$GCCVER" = "x3" ]]; then
-- AC_MSG_RESULT(Turning on gcc 3 optimisations)
-- CFLAGS="$CFLAGS -fno-math-errno"
-- fi
-- case "$CFLAGS" in
-- *mcpu*|*march*) AC_MSG_RESULT(Skipping target optimisations)
-- ;;
-- *) case "$target_cpu" in
-- i386) AC_MSG_RESULT(Turning on i386 optimisations)
-- CFLAGS="$CFLAGS -march=i386 -ffast-math"
-- ;;
-- i486) AC_MSG_RESULT(Turning on i486 optimisations)
-- CFLAGS="$CFLAGS -march=i486 -ffast-math"
-- ;;
-- i586) AC_MSG_RESULT(Turning on pentium optimisations)
-- # cannot do malign-double as we link to other libraries and
-- # it would break binary compatibility
-- CFLAGS="$CFLAGS -march=pentium -ffast-math"
-- ;;
-- i?86) AC_MSG_RESULT(Turning on i686 optimisations)
-- # cannot do malign-double as we link to other libraries and
-- # it would break binary compatibility
-- CFLAGS="$CFLAGS -march=i686 -ffast-math"
-- ;;
-- alpha*) AC_MSG_RESULT(Adding -mieee for Alpha)
-- CFLAGS="$CFLAGS -mieee"
-- ;;
-- *) AC_MSG_RESULT(Sorry unknown target CPU)
-- ;;
-- esac
-- esac
-- else
-- AC_MSG_WARN(You did not opt for gcc optimisations!)
-- optimum=no
-- fi
-- fi
- AC_CHECK_LIB(jpeg, jpeg_start_compress,
- [ MY_LIBS="-ljpeg $MY_LIBS"; AC_DEFINE(JPEG, 1, [JPEG features]) ])
-
-@@ -305,6 +261,7 @@
- AC_CHECK_SIZEOF(unsigned long, 4)
- AC_CHECK_SIZEOF(unsigned long long, 8)
- AC_CHECK_HEADERS(sys/param.h)
-+ AC_CHECK_HEADERS(sys/time.h)
- AC_CHECK_HEADERS(bzlib.h)
- AC_CHECK_HEADERS(zlib.h)
- AC_CHECK_HEADERS(tcl8.0.h)