summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-emulation/fbzx/fbzx-1.6.ebuild')
-rw-r--r--games-emulation/fbzx/fbzx-1.6.ebuild40
1 files changed, 40 insertions, 0 deletions
diff --git a/games-emulation/fbzx/fbzx-1.6.ebuild b/games-emulation/fbzx/fbzx-1.6.ebuild
new file mode 100644
index 000000000000..b0f4a8782953
--- /dev/null
+++ b/games-emulation/fbzx/fbzx-1.6.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/games-emulation/fbzx/fbzx-1.6.ebuild,v 1.1 2006/02/28 16:52:06 mr_bones_ Exp $
+
+inherit eutils toolchain-funcs games
+
+DESCRIPTION="A Sinclair Spectrum emulator, designed to work at full screen using the FrameBuffer"
+HOMEPAGE="http://www.rastersoft.com/fbzx.html"
+SRC_URI="http://www.rastersoft.com/descargas/${PN}${PV//./}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+DEPEND="media-libs/libsdl"
+
+S=${WORKDIR}/${PN}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i \
+ -e "s|/usr/share/spectrum|${GAMES_DATADIR}/${PN}|g" \
+ emulator.c || die "sed failed"
+ sed -i \
+ -e "/^CC/s:gcc:$(tc-getCC):" \
+ -e "s/^\(CC =\).*/\1 $(tc-getCC) ${CFLAGS}/" \
+ -e "s:-O2:${CFLAGS}:" \
+ Makefile || die "sed failed"
+}
+
+src_install() {
+ dogamesbin fbzx || die "dogamesbin failed"
+ insinto "${GAMES_DATADIR}/${PN}/roms"
+ doins roms/* || die "doins failed"
+ dodoc CAPABILITIES FAQ PORTS README* TODO VERSIONS
+ prepgamesdirs
+}