summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-arcade/whichwayisup/whichwayisup-0.7.9.ebuild')
-rw-r--r--games-arcade/whichwayisup/whichwayisup-0.7.9.ebuild66
1 files changed, 0 insertions, 66 deletions
diff --git a/games-arcade/whichwayisup/whichwayisup-0.7.9.ebuild b/games-arcade/whichwayisup/whichwayisup-0.7.9.ebuild
deleted file mode 100644
index d277c2c1c154..000000000000
--- a/games-arcade/whichwayisup/whichwayisup-0.7.9.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-arcade/whichwayisup/whichwayisup-0.7.9.ebuild,v 1.12 2013/02/07 22:07:08 ulm Exp $
-
-EAPI=3
-PYTHON_DEPEND="2"
-inherit eutils python games
-
-MY_PV=${PV//./}
-MY_P=${PN}_b${MY_PV}
-DESCRIPTION="A traditional and challenging 2D platformer game with a slight rotational twist"
-HOMEPAGE="http://hectigo.net/puskutraktori/whichwayisup/"
-SRC_URI="http://hectigo.net/puskutraktori/whichwayisup/${MY_P}.zip"
-
-LICENSE="GPL-2 CC-BY-3.0"
-SLOT="0"
-KEYWORDS="amd64 ppc x86"
-IUSE=""
-
-DEPEND="app-arch/unzip"
-RDEPEND=">=dev-python/pygame-1.6"
-
-S=${WORKDIR}/${PN}
-
-pkg_setup() {
- python_set_active_version 2
- games_pkg_setup
-}
-
-src_prepare() {
- sed -i \
- -e "s:libdir\ =\ .*:libdir\ =\ \"$(games_get_libdir)/${PN}\":" \
- run_game.py \
- || die "Changing library path failed"
- sed -i \
- -e "s:data_dir\ =\ .*:data_dir\ =\ \"${GAMES_DATADIR}/${PN}\":" \
- lib/data.py \
- || die "Changing data path failed"
- rm data/pictures/Thumbs.db
- python_convert_shebangs -r 2 run_game.py
-}
-
-src_install() {
- newgamesbin run_game.py ${PN} || die "newgamesbin failed"
-
- insinto "$(games_get_libdir)/${PN}"
- doins lib/*.py || die "doins lib failed"
-
- dodoc README.txt changelog.txt
-
- insinto "${GAMES_DATADIR}/${PN}"
- doins -r data/* || die "doins data failed"
-
- newicon "${FILESDIR}"/${PN}-32.xpm ${PN}.xpm
- make_desktop_entry ${PN} "Which Way Is Up?"
- prepgamesdirs
-}
-
-pkg_postinst() {
- python_mod_optimize "$(games_get_libdir)/${PN}"
- games_pkg_postinst
-}
-
-pkg_postrm() {
- python_mod_cleanup "$(games_get_libdir)/${PN}"
-}