summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'games-action/luola/luola-1.3.0-r1.ebuild')
-rw-r--r--games-action/luola/luola-1.3.0-r1.ebuild25
1 files changed, 12 insertions, 13 deletions
diff --git a/games-action/luola/luola-1.3.0-r1.ebuild b/games-action/luola/luola-1.3.0-r1.ebuild
index 5ba04b3c8eb6..8eecf19e57d2 100644
--- a/games-action/luola/luola-1.3.0-r1.ebuild
+++ b/games-action/luola/luola-1.3.0-r1.ebuild
@@ -1,17 +1,18 @@
-# Copyright 1999-2006 Gentoo Foundation
+# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/games-action/luola/luola-1.3.0-r1.ebuild,v 1.2 2006/11/27 01:24:39 blubb Exp $
+# $Header: /var/cvsroot/gentoo-x86/games-action/luola/luola-1.3.0-r1.ebuild,v 1.3 2009/01/05 17:39:11 mr_bones_ Exp $
+EAPI=2
inherit eutils games
DESCRIPTION="A 2D multiplayer arcade game resembling V-Wing"
HOMEPAGE="http://luolamies.org/software/luola/"
-PATCHES="http://luolamies.org/software/luola/luola-1.3.0-1.patch
+PATCH_SET="http://luolamies.org/software/luola/luola-1.3.0-1.patch
http://luolamies.org/software/luola/luola-1.3.0-2.patch"
SRC_URI="http://luolamies.org/software/luola/${P}.tar.gz
- http://www.luolamies.org/software/luola/stdlevels-5.2.tar.gz
- http://www.luolamies.org/software/luola/nostalgia-1.1.tar.gz
- ${PATCHES}"
+ http://www.luolamies.org/software/luola/stdlevels-6.0.tar.gz
+ http://www.luolamies.org/software/luola/nostalgia-1.2.tar.gz
+ ${PATCH_SET}"
LICENSE="GPL-2"
SLOT="0"
@@ -24,24 +25,22 @@ DEPEND="media-libs/libsdl
media-libs/sdl-mixer
media-libs/sdl-ttf"
-src_unpack() {
+src_prepare() {
local p
- unpack ${A}
cd "${S}/src"
- for p in ${PATCHES}
+ for p in ${PATCH_SET}
do
epatch "${DISTDIR}/${p##*/}"
done
}
-src_compile() {
- egamesconf --enable-sound || die
- emake || die "emake failed"
+src_configure() {
+ egamesconf --enable-sound
}
src_install() {
- make DESTDIR="${D}" install || die "make install failed"
+ emake DESTDIR="${D}" install || die "emake install failed"
insinto "${GAMES_DATADIR}"/${PN}/levels
doins "${WORKDIR}"/*.{lev,png} || die "doins failed"
dodoc AUTHORS ChangeLog DATAFILE FAQ LEVELFILE README TODO \