summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/mingw-runtime/mingw-runtime-3.10.ebuild4
-rw-r--r--dev-util/mingw-runtime/mingw-runtime-3.9.ebuild4
2 files changed, 4 insertions, 4 deletions
diff --git a/dev-util/mingw-runtime/mingw-runtime-3.10.ebuild b/dev-util/mingw-runtime/mingw-runtime-3.10.ebuild
index 9dc6044fdb8f..853a9dc62d67 100644
--- a/dev-util/mingw-runtime/mingw-runtime-3.10.ebuild
+++ b/dev-util/mingw-runtime/mingw-runtime-3.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/mingw-runtime/mingw-runtime-3.10.ebuild,v 1.3 2006/09/24 14:11:15 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/mingw-runtime/mingw-runtime-3.10.ebuild,v 1.4 2006/09/26 06:18:05 vapier Exp $
# This version does not work as the configure script expects the installed
# cross-compiler to be able to link binaries ... except we haven't provided
@@ -52,7 +52,7 @@ src_unpack() {
src_compile() {
just_headers && return 0
- strip-unsupported-flags
+ CHOST=${CTARGET} strip-unsupported-flags
econf \
--host=${CTARGET} \
--prefix=/usr/${CTARGET} \
diff --git a/dev-util/mingw-runtime/mingw-runtime-3.9.ebuild b/dev-util/mingw-runtime/mingw-runtime-3.9.ebuild
index 605469e5d934..06208d715533 100644
--- a/dev-util/mingw-runtime/mingw-runtime-3.9.ebuild
+++ b/dev-util/mingw-runtime/mingw-runtime-3.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/mingw-runtime/mingw-runtime-3.9.ebuild,v 1.3 2006/09/24 14:11:15 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/mingw-runtime/mingw-runtime-3.9.ebuild,v 1.4 2006/09/26 06:18:05 vapier Exp $
export CBUILD=${CBUILD:-${CHOST}}
export CTARGET=${CTARGET:-${CHOST}}
@@ -50,7 +50,7 @@ src_unpack() {
src_compile() {
just_headers && return 0
- strip-unsupported-flags
+ CHOST=${CTARGET} strip-unsupported-flags
econf \
--host=${CTARGET} \
--prefix=/usr/${CTARGET} \