summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/dwarves/dwarves-1.3.ebuild')
-rw-r--r--dev-util/dwarves/dwarves-1.3.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-util/dwarves/dwarves-1.3.ebuild b/dev-util/dwarves/dwarves-1.3.ebuild
new file mode 100644
index 000000000000..f9552c6fef56
--- /dev/null
+++ b/dev-util/dwarves/dwarves-1.3.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/dwarves/dwarves-1.3.ebuild,v 1.1 2007/12/30 19:01:03 flameeyes Exp $
+
+inherit toolchain-funcs multilib cmake-utils flag-o-matic
+
+DESCRIPTION="pahole (Poke-a-Hole) and other DWARF2 utilities"
+HOMEPAGE="http://git.kernel.org/?p=linux/kernel/git/acme/pahole.git;a=summary"
+SRC_URI="http://userweb.kernel.org/~acme/dwarves/${P}.tar.bz2"
+
+LICENSE="GPL-2" # only
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="debug"
+
+RDEPEND=">=dev-libs/elfutils-0.131"
+
+S=${WORKDIR}
+
+src_compile() {
+ tc-export CC CXX LD
+
+ use debug || append-flags -DNDEBUG
+
+ mycmakeargs="-D__LIB=$(get_libdir)"
+ cmake-utils_src_compile
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ dodoc README README.ctracer
+}