summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-util/cook/cook-2.18.ebuild')
-rw-r--r--dev-util/cook/cook-2.18.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/dev-util/cook/cook-2.18.ebuild b/dev-util/cook/cook-2.18.ebuild
new file mode 100644
index 000000000000..ea4849de9ef8
--- /dev/null
+++ b/dev-util/cook/cook-2.18.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# Maintainer: Tools Team <tools@gentoo.org>
+# Author: Sean Mitchell <sean@arawak.tzo.org>
+# /space/gentoo/cvsroot/gentoo-x86/skel.build,v 1.11 2001/12/06 22:12:34 drobbins Exp
+
+S=${WORKDIR}/${P}
+DESCRIPTION="Cook is a tool for constructing files. It is a replacement for make."
+SRC_URI="http://www.canb.auug.org.au/~millerp/cook/${P}.tar.gz"
+HOMEPAGE="http://www.canb.auug.org.au/~millerp/cook/cook.html"
+DEPEND="sys-devel/bison"
+
+src_compile()
+{
+ ./configure --prefix=/usr || die "./configure failed"
+
+ # doesn't seem to like emake
+ make || die
+}
+
+
+src_install ()
+{
+
+ # we'll hijack the RPM_BUILD_ROOT variable which is intended for a
+ # similiar purpose anyway
+ make RPM_BUILD_ROOT=${D} install || die
+}
+