summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-libs/wayland/wayland-1.0.6.ebuild')
-rw-r--r--dev-libs/wayland/wayland-1.0.6.ebuild48
1 files changed, 48 insertions, 0 deletions
diff --git a/dev-libs/wayland/wayland-1.0.6.ebuild b/dev-libs/wayland/wayland-1.0.6.ebuild
new file mode 100644
index 000000000000..293d65f8de13
--- /dev/null
+++ b/dev-libs/wayland/wayland-1.0.6.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-libs/wayland/wayland-1.0.6.ebuild,v 1.1 2013/04/21 21:29:05 chithanh Exp $
+
+EAPI=5
+
+EGIT_REPO_URI="git://anongit.freedesktop.org/git/${PN}/${PN}"
+
+if [[ ${PV} = 9999* ]]; then
+ GIT_ECLASS="git-2"
+ EXPERIMENTAL="true"
+fi
+
+inherit autotools toolchain-funcs $GIT_ECLASS
+
+DESCRIPTION="Wayland protocol libraries"
+HOMEPAGE="http://wayland.freedesktop.org/"
+
+if [[ $PV = 9999* ]]; then
+ SRC_URI="${SRC_PATCHES}"
+else
+ SRC_URI="http://wayland.freedesktop.org/releases/${P}.tar.xz"
+fi
+
+LICENSE="CC-BY-SA-3.0 MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~hppa ~ia64 ~ppc ~ppc64 ~x86"
+IUSE="doc static-libs"
+
+RDEPEND="dev-libs/expat
+ virtual/libffi"
+DEPEND="${RDEPEND}
+ doc? ( app-doc/doxygen )"
+
+src_prepare() {
+ if [[ ${PV} = 9999* ]]; then
+ eautoreconf
+ fi
+}
+
+src_configure() {
+ myconf="$(use_enable static-libs static) \
+ $(use_enable doc documentation)"
+ if tc-is-cross-compiler ; then
+ myconf+=" --disable-scanner"
+ fi
+ econf ${myconf}
+}