summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang')
-rw-r--r--dev-lang/lua/ChangeLog9
-rw-r--r--dev-lang/lua/lua-5.1.3-r2.ebuild110
-rw-r--r--dev-lang/lua/lua-5.1.4.ebuild (renamed from dev-lang/lua/lua-5.1.3-r1.ebuild)19
3 files changed, 19 insertions, 119 deletions
diff --git a/dev-lang/lua/ChangeLog b/dev-lang/lua/ChangeLog
index 0b2b96673a87..ba254b423773 100644
--- a/dev-lang/lua/ChangeLog
+++ b/dev-lang/lua/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-lang/lua
# Copyright 2002-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/lua/ChangeLog,v 1.117 2008/09/13 20:24:39 solar Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/lua/ChangeLog,v 1.118 2008/09/28 10:00:26 mabi Exp $
+
+*lua-5.1.4 (28 Sep 2008)
+
+ 28 Sep 2008; Matti Bickel <mabi@gentoo.org> -lua-5.1.3-r1.ebuild,
+ -lua-5.1.3-r2.ebuild, +lua-5.1.4.ebuild:
+ rev bump, this is a bugfix release including all fixes from lua-5.1.3-r*,
+ removed old versions
13 Sep 2008; <solar@gentoo.org> lua-5.1.3-r4.ebuild:
- make lua partially cross compile aware. More work might be needed
diff --git a/dev-lang/lua/lua-5.1.3-r2.ebuild b/dev-lang/lua/lua-5.1.3-r2.ebuild
deleted file mode 100644
index 3bd8b735c07e..000000000000
--- a/dev-lang/lua/lua-5.1.3-r2.ebuild
+++ /dev/null
@@ -1,110 +0,0 @@
-# Copyright 1999-2008 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/lua/lua-5.1.3-r2.ebuild,v 1.4 2008/05/18 15:09:33 armin76 Exp $
-
-inherit eutils portability versionator
-
-DESCRIPTION="A powerful light-weight programming language designed for extending applications"
-HOMEPAGE="http://www.lua.org/"
-SRC_URI="http://www.lua.org/ftp/${P}.tar.gz"
-
-LICENSE="MIT"
-SLOT="0"
-KEYWORDS="alpha ~amd64 ~arm ~hppa ia64 ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86"
-IUSE="deprecated readline static"
-
-DEPEND="readline? ( sys-libs/readline )"
-
-src_unpack() {
- local PATCH_PV=$(get_version_component_range 1-2)
- unpack ${A}
- cd "${S}"
-
- epatch "${FILESDIR}"/${PN}-${PATCH_PV}-make.patch
- epatch "${FILESDIR}"/${PN}-${PATCH_PV}-module_paths.patch
-
- EPATCH_SOURCE="${FILESDIR}/${PV}" EPATCH_SUFFIX="upstream.patch" epatch
-
- # correct lua versioning
- sed -i -e 's/\(LIB_VERSION = \)6:1:1/\16:3:1/' src/Makefile
-
- sed -i -e 's:\(/README\)\("\):\1.gz\2:g' doc/readme.html
-
- if ! use deprecated ; then
- epatch "${FILESDIR}"/${P}-deprecated.patch
- epatch "${FILESDIR}"/${P}-test.patch
- fi
-
- if ! use readline ; then
- epatch "${FILESDIR}"/${PN}-${PATCH_PV}-readline.patch
- fi
-
- # Using dynamic linked lua is not recommended upstream for performance
- # reasons. http://article.gmane.org/gmane.comp.lang.lua.general/18519
- # Mainly, this is of concern if your arch is poor with GPRs, like x86
- # Not that this only affects the interpreter binary (named lua), not the lua
- # compiler (built statically) nor the lua libraries (both shared and static
- # are installed)
- if use static ; then
- epatch "${FILESDIR}"/${PN}-${PATCH_PV}-make_static.patch
- fi
-
- # We want packages to find our things...
- sed -i -e 's:/usr/local:/usr:' etc/lua.pc
-}
-
-src_compile() {
- myflags=
- # what to link to liblua
- liblibs="-lm"
- mycflags="${mycflags} -DLUA_USE_LINUX"
- liblibs="${liblibs} $(dlopen_lib)"
-
- # what to link to the executables
- mylibs=
- if use readline; then
- mylibs="-lreadline"
- fi
-
- cd src
- emake CFLAGS="${mycflags} ${CFLAGS}" \
- RPATH="/usr/$(get_libdir)/" \
- LUA_LIBS="${mylibs}" \
- LIB_LIBS="${liblibs}" \
- V=${PV} \
- gentoo_all || die "emake failed"
-
- mv lua_test ../test/lua.static
-}
-
-src_install() {
- emake INSTALL_TOP="${D}/usr/" INSTALL_LIB="${D}/usr/$(get_libdir)/" \
- V=${PV} gentoo_install \
- || die "emake install gentoo_install failed"
-
- dodoc HISTORY README
- dohtml doc/*.html doc/*.gif
-
- insinto /usr/share/pixmaps
- doins etc/lua.ico
- insinto /usr/$(get_libdir)/pkgconfig
- doins etc/lua.pc
-
- doman doc/lua.1 doc/luac.1
-}
-
-src_test() {
- local positive="bisect cf echo env factorial fib fibfor hello printf sieve
- sort trace-calls trace-globals"
- local negative="readonly"
- local test
-
- cd "${S}"
- for test in ${positive}; do
- test/lua.static test/${test}.lua || die "test $test failed"
- done
-
- for test in ${negative}; do
- test/lua.static test/${test}.lua && die "test $test failed"
- done
-}
diff --git a/dev-lang/lua/lua-5.1.3-r1.ebuild b/dev-lang/lua/lua-5.1.4.ebuild
index 3e13c3d719e8..b75d588af811 100644
--- a/dev-lang/lua/lua-5.1.3-r1.ebuild
+++ b/dev-lang/lua/lua-5.1.4.ebuild
@@ -1,8 +1,10 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/lua/lua-5.1.3-r1.ebuild,v 1.9 2008/05/18 16:27:58 maekke Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/lua/lua-5.1.4.ebuild,v 1.1 2008/09/28 10:00:26 mabi Exp $
-inherit eutils portability versionator
+EAPI="1"
+
+inherit eutils portability versionator toolchain-funcs
DESCRIPTION="A powerful light-weight programming language designed for extending applications"
HOMEPAGE="http://www.lua.org/"
@@ -10,8 +12,8 @@ SRC_URI="http://www.lua.org/ftp/${P}.tar.gz"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~alpha amd64 ~arm hppa ~ia64 ppc ppc64 ~s390 ~sh sparc x86"
-IUSE="deprecated readline static"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="+deprecated readline static"
DEPEND="readline? ( sys-libs/readline )"
@@ -23,10 +25,10 @@ src_unpack() {
epatch "${FILESDIR}"/${PN}-${PATCH_PV}-make.patch
epatch "${FILESDIR}"/${PN}-${PATCH_PV}-module_paths.patch
- EPATCH_SOURCE="${FILESDIR}/${PV}" EPATCH_SUFFIX="upstream.patch" epatch
+ # EPATCH_SOURCE="${FILESDIR}/${PV}" EPATCH_SUFFIX="upstream.patch" epatch
# correct lua versioning
- sed -i -e 's/\(LIB_VERSION = \)6:1:1/\16:3:1/' src/Makefile
+ sed -i -e 's/\(LIB_VERSION = \)6:1:1/\16:4:1/' src/Makefile
sed -i -e 's:\(/README\)\("\):\1.gz\2:g' doc/readme.html
@@ -54,6 +56,7 @@ src_unpack() {
}
src_compile() {
+ tc-export CC
myflags=
# what to link to liblua
liblibs="-lm"
@@ -67,8 +70,8 @@ src_compile() {
fi
cd src
- emake CFLAGS="${mycflags} ${CFLAGS}" \
- RPATH="/usr/$(get_libdir)/" \
+ emake CC="${CC}" CFLAGS="${mycflags} ${CFLAGS}" \
+ RPATH="${ROOT}/usr/$(get_libdir)/" \
LUA_LIBS="${mylibs}" \
LIB_LIBS="${liblibs}" \
V=${PV} \