summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/python/python-2.6.8-r1.ebuild')
-rw-r--r--dev-lang/python/python-2.6.8-r1.ebuild6
1 files changed, 2 insertions, 4 deletions
diff --git a/dev-lang/python/python-2.6.8-r1.ebuild b/dev-lang/python/python-2.6.8-r1.ebuild
index b711dee59e94..3f64b971a42f 100644
--- a/dev-lang/python/python-2.6.8-r1.ebuild
+++ b/dev-lang/python/python-2.6.8-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2013 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.8-r1.ebuild,v 1.20 2013/05/09 17:48:03 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/python/python-2.6.8-r1.ebuild,v 1.21 2013/05/25 22:32:46 floppym Exp $
EAPI="2"
WANT_AUTOMAKE="none"
@@ -251,7 +251,7 @@ src_test() {
done
# Rerun failed tests in verbose mode (regrtest -w).
- emake test EXTRATESTOPTS="-w" < /dev/tty
+ PYTHONDONTWRITEBYTECODE="" emake test EXTRATESTOPTS="-w" < /dev/tty
local result="$?"
for test in ${skipped_tests}; do
@@ -267,8 +267,6 @@ src_test() {
elog "cd '${EPREFIX}/usr/$(get_libdir)/python${SLOT}/test'"
elog "and run the tests separately."
- python_disable_pyc
-
if [[ "${result}" -ne 0 ]]; then
die "emake test failed"
fi