summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/php/php-5.2.6-r5.ebuild')
-rw-r--r--dev-lang/php/php-5.2.6-r5.ebuild5
1 files changed, 3 insertions, 2 deletions
diff --git a/dev-lang/php/php-5.2.6-r5.ebuild b/dev-lang/php/php-5.2.6-r5.ebuild
index 67af697e99fc..56e133d993a1 100644
--- a/dev-lang/php/php-5.2.6-r5.ebuild
+++ b/dev-lang/php/php-5.2.6-r5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/php-5.2.6-r5.ebuild,v 1.2 2008/07/19 14:33:44 hoffie Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/php/php-5.2.6-r5.ebuild,v 1.3 2008/07/20 09:35:46 hoffie Exp $
CGI_SAPI_USE="discard-path force-cgi-redirect"
APACHE2_SAPI_USE="concurrentmodphp threads"
@@ -192,7 +192,8 @@ src_unpack() {
src_compile() {
# bug 217392 (autconf-2.62 behavior changes)
- append-flags -D_GNU_SOURCE
+ export CFLAGS="${CFLAGS} -D_GNU_SOURCE"
+ export CXXFLAGS="${CFLAGS} -D_GNU_SOURCE"
if use fastbuild && [[ -n "${FASTBUILD_PATCH}" ]] ; then
src_compile_fastbuild
else