summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/mono-basic/mono-basic-2.0.ebuild')
-rw-r--r--dev-lang/mono-basic/mono-basic-2.0.ebuild36
1 files changed, 36 insertions, 0 deletions
diff --git a/dev-lang/mono-basic/mono-basic-2.0.ebuild b/dev-lang/mono-basic/mono-basic-2.0.ebuild
new file mode 100644
index 000000000000..b1a79b2b5e37
--- /dev/null
+++ b/dev-lang/mono-basic/mono-basic-2.0.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-lang/mono-basic/mono-basic-2.0.ebuild,v 1.1 2008/11/19 22:46:49 loki_val Exp $
+
+inherit mono multilib
+
+DESCRIPTION="Visual Basic .NET Runtime and Class Libraries"
+HOMEPAGE="http://www.go-mono.com"
+SRC_URI="http://ftp.novell.com/pub/mono/sources/${PN}/${P}.tar.bz2"
+
+LICENSE="|| ( GPL-2 LGPL-2 X11 )"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND="=dev-lang/mono-${PV}*"
+DEPEND="${RDEPEND}"
+
+RESTRICT="test"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ sed -i -e "s|\(mono_libdir=\${exec_prefix}\)/lib|\1/$(get_libdir)|" \
+ configure || die "sed failed"
+}
+
+src_compile() {
+ econf || die "configure failed"
+ emake || die "make failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "install failed"
+}