summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-lang/gnat-gcc/gnat-gcc-4.1.0.ebuild')
-rw-r--r--dev-lang/gnat-gcc/gnat-gcc-4.1.0.ebuild38
1 files changed, 0 insertions, 38 deletions
diff --git a/dev-lang/gnat-gcc/gnat-gcc-4.1.0.ebuild b/dev-lang/gnat-gcc/gnat-gcc-4.1.0.ebuild
deleted file mode 100644
index dc7708ee17c7..000000000000
--- a/dev-lang/gnat-gcc/gnat-gcc-4.1.0.ebuild
+++ /dev/null
@@ -1,38 +0,0 @@
-# Copyright 1999-2006 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-lang/gnat-gcc/gnat-gcc-4.1.0.ebuild,v 1.2 2006/10/25 13:47:52 george Exp $
-
-inherit gnatbuild
-
-DESCRIPTION="GNAT Ada Compiler - gcc version"
-HOMEPAGE="http://gcc.gnu.org/"
-LICENSE="GMGPL"
-
-# SLOT is set in gnatbuild.eclass, depends only on PV (basically SLOT=GCCBRANCH)
-# so the URI's are static.
-SRC_URI="ftp://gcc.gnu.org/pub/gcc/releases/gcc-${PV}/gcc-core-${PV}.tar.bz2
- ftp://gcc.gnu.org/pub/gcc/releases/gcc-${PV}/gcc-ada-${PV}.tar.bz2
- x86? ( http://mirrors/gentoo/gnatboot-${BOOT_SLOT}-i386.tar.bz2 )
- amd64? ( http://mirrors/gentoo/gnatboot-${BOOT_SLOT}-amd64.tar.bz2 )"
-
-KEYWORDS="~amd64 ~x86"
-
-src_unpack() {
- gnatbuild_src_unpack
-
- #fixup some hardwired flags
- cd ${S}/gcc/ada
-
- # universal gcc -> gnatgcc substitution occasionally produces lines too long
- # and then build halts on the style check or even produces wrong code..
- sed -i -e 's:(Last3 = "gnatgcc"):(Last3 = "gcc"):' makegpr.adb &&
- sed -i -e 's:and Nam is "gnatgcc":and Nam is "gcc":' osint.ads ||
- die "reversing [gnat]gcc substitution in comments failed"
-}
-
-
-src_compile() {
- # looks like gnatlib_and_tools and gnatlib_shared have become part of
- # bootstrap
- gnatbuild_src_compile configure make-tools bootstrap
-}