summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-java/gnu-classpath/gnu-classpath-0.20.ebuild')
-rw-r--r--dev-java/gnu-classpath/gnu-classpath-0.20.ebuild34
1 files changed, 19 insertions, 15 deletions
diff --git a/dev-java/gnu-classpath/gnu-classpath-0.20.ebuild b/dev-java/gnu-classpath/gnu-classpath-0.20.ebuild
index 9722680b667e..fa51a4e40f6a 100644
--- a/dev-java/gnu-classpath/gnu-classpath-0.20.ebuild
+++ b/dev-java/gnu-classpath/gnu-classpath-0.20.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-java/gnu-classpath/gnu-classpath-0.20.ebuild,v 1.2 2006/02/04 18:13:29 wormo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-java/gnu-classpath/gnu-classpath-0.20.ebuild,v 1.3 2006/02/05 14:25:43 betelgeuse Exp $
-inherit eutils autotools
+inherit eutils
MY_P=${P/gnu-/}
DESCRIPTION="Free core class libraries for use with virtual machines and compilers for the Java programming language"
@@ -22,28 +22,32 @@ RDEPEND="alsa? ( media-libs/alsa-lib )
dssi? ( >=media-libs/dssi-0.9 )
gtk? ( >=x11-libs/gtk+-2.4
>=dev-libs/glib-2.0
- virtual/x11
+ || ( (
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ x11-libs/libXtst
+ )
+ virtual/x11
+ )
cairo? ( >=x11-libs/cairo-0.5.0 )
)
xml2? ( >=dev-libs/libxml2-2.6.8 >=dev-libs/libxslt-1.1.11 )"
DEPEND="app-arch/zip
dev-java/jikes
+ gtk? ( || ( (
+ x11-libs/libXrender
+ x11-proto/xextproto
+ x11-proto/xproto
+ )
+ virtual/x11
+ )
+ )
${REPEND}"
S=${WORKDIR}/${MY_P}
-src_unpack() {
- unpack ${A}
- cd ${S}
-
-# cp ${FILESDIR}/${PV}-dssi_data.h native/jni/midi-dssi/dssi_data.h \
-# || die "Copying dssi_data.h failed."
-
-# epatch ${FILESDIR}/${PV}-dssi.patch
- eautoconf
-}
-
src_compile() {
# Note: This is written in a way to easily support GCJ and other compilers
# at a later point. Currently Gentoo uses mainly GCJ 3.3 (from the
@@ -69,7 +73,7 @@ src_compile() {
}
src_install() {
- einstall || die "einstall failed"
+ make DESTDIR="${D}" install || die "make install failed"
dodoc AUTHORS BUGS ChangeLog* HACKING NEWS README THANKYOU TODO
}