summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/texmath/texmath-0.6.1.1.ebuild')
-rw-r--r--dev-haskell/texmath/texmath-0.6.1.1.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/dev-haskell/texmath/texmath-0.6.1.1.ebuild b/dev-haskell/texmath/texmath-0.6.1.1.ebuild
new file mode 100644
index 000000000000..361bccd0893a
--- /dev/null
+++ b/dev-haskell/texmath/texmath-0.6.1.1.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/texmath/texmath-0.6.1.1.ebuild,v 1.1 2012/11/25 06:09:58 gienah Exp $
+
+EAPI=5
+
+# ebuild generated by hackport 0.3.9999
+
+CABAL_FEATURES="bin lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Conversion of LaTeX math formulas to MathML or OMML."
+HOMEPAGE="http://github.com/jgm/texmath"
+SRC_URI="mirror://hackage/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~x86"
+IUSE="cgi test"
+
+RDEPEND=">=dev-haskell/parsec-3:=[profile?]
+ dev-haskell/syb:=[profile?]
+ dev-haskell/xml:=[profile?]
+ >=dev-lang/ghc-6.10.4:=
+ cgi? ( dev-haskell/json:=[profile?]
+ dev-haskell/cgi:=[profile?]
+ dev-haskell/utf8-string:=[profile?]
+ )
+ "
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.6"
+
+src_configure() {
+ cabal_src_configure \
+ $(cabal_flag cgi) \
+ $(cabal_flag test)
+}
+
+src_install() {
+ cabal_src_install
+
+ # remove test and it's data
+ rm -f "${ED}/usr/bin/texmath" 2> /dev/null
+ rm -rf "${ED}/usr/share/${P}"/ghc-*/tests 2> /dev/null
+}