summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-haskell/hashtables/hashtables-1.0.1.3.ebuild')
-rw-r--r--dev-haskell/hashtables/hashtables-1.0.1.3.ebuild27
1 files changed, 27 insertions, 0 deletions
diff --git a/dev-haskell/hashtables/hashtables-1.0.1.3.ebuild b/dev-haskell/hashtables/hashtables-1.0.1.3.ebuild
new file mode 100644
index 000000000000..9110b7f4ce38
--- /dev/null
+++ b/dev-haskell/hashtables/hashtables-1.0.1.3.ebuild
@@ -0,0 +1,27 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-haskell/hashtables/hashtables-1.0.1.3.ebuild,v 1.1 2012/04/14 10:30:36 gienah Exp $
+
+# ebuild generated by hackport 0.2.17.9999
+
+EAPI=4
+
+CABAL_FEATURES="lib profile haddock hoogle hscolour"
+inherit haskell-cabal
+
+DESCRIPTION="Mutable hash tables in the ST monad"
+HOMEPAGE="http://github.com/gregorycollins/hashtables"
+SRC_URI="http://hackage.haskell.org/packages/archive/${PN}/${PV}/${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+RDEPEND=">=dev-haskell/hashable-1.1[profile?]
+ <dev-haskell/hashable-2[profile?]
+ dev-haskell/primitive[profile?]
+ >=dev-haskell/vector-0.7[profile?]
+ >=dev-lang/ghc-6.10.1"
+DEPEND="${RDEPEND}
+ >=dev-haskell/cabal-1.8"