summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-games/ogre')
-rw-r--r--dev-games/ogre/files/0.15.1-nocg.patch30
-rw-r--r--dev-games/ogre/ogre-0.15.1.ebuild66
2 files changed, 0 insertions, 96 deletions
diff --git a/dev-games/ogre/files/0.15.1-nocg.patch b/dev-games/ogre/files/0.15.1-nocg.patch
deleted file mode 100644
index 463dce704339..000000000000
--- a/dev-games/ogre/files/0.15.1-nocg.patch
+++ /dev/null
@@ -1,30 +0,0 @@
---- configure.in.orig 2004-04-14 12:04:49.000000000 +0200
-+++ configure.in 2004-04-14 12:05:43.000000000 +0200
-@@ -44,12 +44,6 @@
- ****************************************************************]))
- AC_CHECK_LIB(ILU, iluFlipImage)
- AC_CHECK_LIB(pthread, pthread_create)
--AC_CHECK_LIB(Cg, cgCreateProgram,,AC_MSG_ERROR([
--****************************************************************
--* You do not have the nVidia Cg libraries installed. *
--* Go to http://developer.nvidia.com/object/cg_toolkit.html *
--* (Click on Cg_Linux.tar.gz). *
--****************************************************************]))
- AC_CHECK_FUNC(snprintf, AC_DEFINE(HAVE_SNPRINTF,,snprintf))
- AC_CHECK_FUNC(vsnprintf, AC_DEFINE(HAVE_VSNPRINTF,,vsnprintf))
-
-@@ -94,9 +88,6 @@
- PlugIns/BSPSceneManager/Makefile \
- PlugIns/BSPSceneManager/src/Makefile \
- PlugIns/BSPSceneManager/include/Makefile \
-- PlugIns/CgProgramManager/Makefile \
-- PlugIns/CgProgramManager/src/Makefile \
-- PlugIns/CgProgramManager/include/Makefile \
- PlugIns/FileSystem/Makefile \
- PlugIns/FileSystem/src/Makefile \
- PlugIns/FileSystem/include/Makefile \
---- PlugIns/Makefile.am.orig 2004-04-14 12:05:54.000000000 +0200
-+++ PlugIns/Makefile.am 2004-04-14 12:06:03.000000000 +0200
-@@ -1 +1 @@
--SUBDIRS = BSPSceneManager CgProgramManager FileSystem ParticleFX OctreeSceneManager GuiElements NatureSceneManager
-+SUBDIRS = BSPSceneManager FileSystem ParticleFX OctreeSceneManager GuiElements NatureSceneManager
diff --git a/dev-games/ogre/ogre-0.15.1.ebuild b/dev-games/ogre/ogre-0.15.1.ebuild
deleted file mode 100644
index 774b475404ad..000000000000
--- a/dev-games/ogre/ogre-0.15.1.ebuild
+++ /dev/null
@@ -1,66 +0,0 @@
-# Copyright 1999-2005 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-games/ogre/ogre-0.15.1.ebuild,v 1.3 2005/04/01 23:16:31 vapier Exp $
-
-inherit eutils
-
-DESCRIPTION="Object-oriented Graphics Rendering Engine"
-HOMEPAGE="http://www.ogre3d.org/"
-SRC_URI="mirror://sourceforge/ogre/${PN}-linux_osx-v${PV//./-}.tar.bz2"
-
-LICENSE="LGPL-2.1"
-SLOT="0"
-KEYWORDS="ppc x86"
-IUSE="doc gtk"
-
-RDEPEND="virtual/opengl
- media-libs/libsdl
- =media-libs/freetype-2*
- >=media-libs/devil-1.5
- gtk? (
- =dev-cpp/libglademm-2.0*
- =dev-cpp/gtkmm-2* )
- sys-libs/zlib"
-DEPEND="${RDEPEND}
- x86? ( >=media-gfx/nvidia-cg-toolkit-1.2 )
- amd64? ( >=media-gfx/nvidia-cg-toolkit-1.2 )
- || (
- dev-libs/STLport
- >=sys-devel/gcc-3.0 )"
-
-S="${WORKDIR}/ogrenew"
-
-src_unpack() {
- unpack ${A}
- cd "${S}"
- case "${ARCH}" in
- x86 | amd64)
- ;;
- *)
- einfo "Removing nVidia Cg dependency on this arch"
- epatch "${FILESDIR}/${PV}-nocg.patch"
- rm -rf "${S}/autom4te.cache"
- ./bootstrap
- ;;
- esac
-}
-
-src_compile() {
- local myconf="cli"
-
- use gtk && myconf="gtk"
-
- econf --with-cfgtk=${myconf} || die
- emake || die "emake failed"
-}
-
-src_install() {
- make DESTDIR="${D}" install || die "make install failed"
- if use doc ; then
- dohtml -r Docs/* Docs/Tutorials/*
- fi
- insinto /usr/share/OGRE/Media
- doins Samples/Media/*
- dodoc AUTHORS BUGS LINUX.DEV README Docs/README.linux
- dohtml Docs/*.html
-}