summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-dotnet/gluezilla/gluezilla-2.6.ebuild')
-rw-r--r--dev-dotnet/gluezilla/gluezilla-2.6.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-dotnet/gluezilla/gluezilla-2.6.ebuild b/dev-dotnet/gluezilla/gluezilla-2.6.ebuild
new file mode 100644
index 000000000000..2cfe910f6616
--- /dev/null
+++ b/dev-dotnet/gluezilla/gluezilla-2.6.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-dotnet/gluezilla/gluezilla-2.6.ebuild,v 1.1 2010/02/21 14:34:16 patrick Exp $
+
+EAPI=2
+
+inherit go-mono mono autotools
+
+DESCRIPTION="A simple library to embed Gecko (xulrunner) in the Mono Winforms WebControl"
+HOMEPAGE="http://mono-project.com/Gluezilla"
+
+LICENSE="LGPL-2 MPL-1.1"
+KEYWORDS="~amd64 ~ppc ~x86"
+SLOT="0"
+IUSE=""
+
+RDEPEND="net-libs/xulrunner:1.9
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-fix-xulrunner-detection.patch" || die "Failed to patch"
+ eautoreconf
+}