summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
Diffstat (limited to 'dev-db/hk_classes/files/hk_classes-amd64.patch')
-rw-r--r--dev-db/hk_classes/files/hk_classes-amd64.patch58
1 files changed, 58 insertions, 0 deletions
diff --git a/dev-db/hk_classes/files/hk_classes-amd64.patch b/dev-db/hk_classes/files/hk_classes-amd64.patch
new file mode 100644
index 000000000000..1bb5ce9ab388
--- /dev/null
+++ b/dev-db/hk_classes/files/hk_classes-amd64.patch
@@ -0,0 +1,58 @@
+diff -Naur hk_classes-0.7.orig/hk_classes/Makefile.am hk_classes-0.7/hk_classes/Makefile.am
+--- hk_classes-0.7.orig/hk_classes/Makefile.am 2004-06-20 15:48:48.000000000 +0200
++++ hk_classes-0.7/hk_classes/Makefile.am 2004-11-21 23:10:13.670882088 +0100
+@@ -1,7 +1,7 @@
+ libdir=@HK_CLASSESDIR@
+ includedir=@HK_CLASSESINCDIR@
+ libhk_classes_la_LDFLAGS = -version-info 6:0:0 @LTLIBICONV@
+-AM_CXXFLAGS= -Wall @PYTHONINC@
++AM_CXXFLAGS= -Wall @PYTHONINC@ -fPIC
+
+ SUBDIRS = .
+
+diff -Naur hk_classes-0.7.orig/hk_mysqlclasses/Makefile.am hk_classes-0.7/hk_mysqlclasses/Makefile.am
+--- hk_classes-0.7.orig/hk_mysqlclasses/Makefile.am 2003-05-22 20:27:14.000000000 +0200
++++ hk_classes-0.7/hk_mysqlclasses/Makefile.am 2004-11-21 23:10:19.127052624 +0100
+@@ -1,7 +1,7 @@
+ libdir=@HK_CLASSESDIR@/drivers
+ INCLUDES= -I../hk_classes -I@MYSQLINCDIR@
+
+-AM_CXXFLAGS= -Wall
++AM_CXXFLAGS= -Wall -fPIC
+
+ libhk_mysqldriver_la_LDFLAGS = -version-info 3:4:0 -lmysqlclient -L../hk_classes -L@MYSQLLIBDIR@ -lhk_classes
+
+diff -Naur hk_classes-0.7.orig/hk_odbcclasses/Makefile.am hk_classes-0.7/hk_odbcclasses/Makefile.am
+--- hk_classes-0.7.orig/hk_odbcclasses/Makefile.am 2003-05-22 20:27:14.000000000 +0200
++++ hk_classes-0.7/hk_odbcclasses/Makefile.am 2004-11-21 23:10:24.672209632 +0100
+@@ -1,6 +1,6 @@
+ libdir=@HK_CLASSESDIR@/drivers
+ INCLUDES= -I../hk_classes -I@ODBCINCDIR@
+-AM_CXXFLAGS= -Wall
++AM_CXXFLAGS= -Wall -fPIC
+
+ libhk_odbcdriver_la_LDFLAGS = -version-info 0:0:0 -l@ODBCLIBRARY@ -L@ODBCLIBDIR@ -lhk_classes -L../hk_classes
+
+diff -Naur hk_classes-0.7.orig/hk_postgresclasses/Makefile.am hk_classes-0.7/hk_postgresclasses/Makefile.am
+--- hk_classes-0.7.orig/hk_postgresclasses/Makefile.am 2003-05-22 20:27:11.000000000 +0200
++++ hk_classes-0.7/hk_postgresclasses/Makefile.am 2004-11-21 23:11:02.304488656 +0100
+@@ -1,6 +1,7 @@
+ libdir=@HK_CLASSESDIR@/drivers
+ INCLUDES= -I../hk_classes -I@POSTGRESINCDIR@
+
++AM_CXXFLAGS= -fPIC
+
+ libhk_postgresdriver_la_LDFLAGS = -version-info 0:1:0 -lpq -lhk_classes -L../hk_classes -L@POSTGRESLIBDIR@
+
+diff -Naur hk_classes-0.7.orig/hk_sqliteclasses/Makefile.am hk_classes-0.7/hk_sqliteclasses/Makefile.am
+--- hk_classes-0.7.orig/hk_sqliteclasses/Makefile.am 2004-07-11 10:04:53.000000000 +0200
++++ hk_classes-0.7/hk_sqliteclasses/Makefile.am 2004-11-21 23:11:09.117452928 +0100
+@@ -1,7 +1,7 @@
+ libdir=@HK_CLASSESDIR@/drivers
+ INCLUDES= -I../hk_classes -I@SQLITEINCDIR@
+
+-AM_CXXFLAGS= -Wall
++AM_CXXFLAGS= -Wall -fPIC
+
+ libhk_sqlite2driver_la_LDFLAGS = -version-info 0:0:0 -lsqlite -L../hk_classes -L@SQLITELIBDIR@ -lhk_classes
+